Can't run any tests

I'm just checking out the jMP for the first time and I'm fairly sure it's not running properly.

For starters, the SceneViewer window is all black. The output window says it's created text boxes at start up but the window remains blank with none of the fps/triangle/etc information I see in the videos. I haven't tried loading a model into it yet, however.

Main problem is the test projects. None seem to run, most spurt out the following error:

SEVERE Application 19:02:00 Uncaught exception thrown in Thread[LWJGL Renderer Thread,6,main]
java.lang.IllegalStateException: Cannot render mesh without shader bound
        at com.jme3.renderer.lwjgl.LwjglRenderer.setVertexAttrib(
        at com.jme3.renderer.lwjgl.LwjglRenderer.setVertexAttrib(
        at com.jme3.renderer.lwjgl.LwjglRenderer.renderMeshDefault(
        at com.jme3.renderer.lwjgl.LwjglRenderer.renderMesh(
        at com.jme3.material.Material.render(
        at com.jme3.renderer.RenderManager.renderGeometry(
        at com.jme3.renderer.queue.RenderQueue.renderGeometryList(
        at com.jme3.renderer.queue.RenderQueue.renderQueue(
        at com.jme3.renderer.RenderManager.flushQueue(
        at com.jme3.renderer.RenderManager.renderViewPort(
        at com.jme3.renderer.RenderManager.render(
        at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(
BUILD SUCCESSFUL (total time: 20 seconds)

That's using LWJGL-OpenGL2 or above but if i run with OpenGL1 some will work, although the mouse doesn't seem to work properly, the view in the jME window won't move properly and I can see the mouse tracking over the rest of my screen momentarily before disappearing again. Others will fail with:

Exception in thread "Thread-4" java.lang.IllegalArgumentException: For material Cube Texture, technique not found: FixedFunc

I have a OpenGL 3.1 graphics card, totally up to date. Win7 x64.

Any ideas, anyone?

Are you using the nightly build? This issue was fixed after the alpha1 release.

I see that in many cases it tries to use the FixedFunc technique even though the card clearly supports shaders, this can only happen if the renderer capability "GLSL100" isn't put properly into the caps set. So I added an additional check in initialization to assume the card supports GLSL if it supports OpenGL2. Hopefully this should fix this issue once and for all.