[committed] Issue 28 in jmonkeyengine: HelloJMEDesktop broken


jMEDesktop which extends Quad has an empty resize() method.

A recent change to Quad made use of the resize method in its constructor.

Since jMEDesktop overwrites it, it broke jMEDesktop.

The solution is to call super.resize(x,y).

Index: src/com/jmex/awt/swingui/JMEDesktop.java
--- src/com/jmex/awt/swingui/JMEDesktop.java   (revision 4077)
+++ src/com/jmex/awt/swingui/JMEDesktop.java   (working copy)
@@ -1360,12 +1360,12 @@
-     * not supported.
+     * Resizing jMEDesktop is not supported.
      * @param width -
      * @param height -
+    @Deprecated
     public void resize( float width, float height ) {
-        //TODO: implement resizing?
-        throw new UnsupportedOperationException( "resizing JMEDesktop not yet implemented!" );
+        super.resize(width, height);

edit: removed writing to logfile

good job :slight_smile:

That issue was reported by me actually, thanks for making the patch :slight_smile:

this is fixed now with r4078.

The crash is fixed, but now keyboard and mouse input don't work on Mac OS X. Although this could have been the case before,  I didn't look at JMEDesktop in ages.

jDeskTop on OSX well may have some nasties left in it; up until jME 2.0 it didn't even run on OSX…

Help us find em :slight_smile:

keeskist, could you check with earlier revision if it worked once?

As basix said, chances are pretty good, that it never worked on os :frowning:

(Sorry for the late reply)

I checked some revisions from a number of months ago, and both of you are right… I can't get JMEDesktop to work with events on Mac…  :?

EDIT: looks like it's reported already at http://code.google.com/p/jmonkeyengine/issues/detail?id=25