Converting to .j3o format in JMEsdk is so slow

hi there
I tried to covert a blend file to j3o but it is so slow about 3 min…
this is my model and whats wrong in it ?

I tried to use ogre xml but I have problems …

1 Like

Can you recheck it in the editor?

1 Like

yes I checked it and covert it to .j3o file in space shift …
but wheels have no animtion channel in j3o file!

Its actually the best to use xbuf, which the sdk can convert to j3o and which should Not have Animation Problems

1 Like

SS editor can do it the same :wink:


can you please telling me what’s wrong in my blend file?

jme doesn’t support the blend format fully.

1 Like

No I mean when I use the ogre format:
animation channels is not accessible in game but in jmeSdk I can play them …
in SE and in SC in sdk , animControls are there and I can play them correctly but not in game…

and when use blend file to convert j3o it so slow and at the end it doesnt contain animation channels …

what about this in the SS editor?

1 Like

No in ss editor model looks good but j3o does not contain or I cant find an animControl…

I mean when you try to convert ogre format to j3o in the SS editor…

1 Like

ok I will check it …

If the sdk has the controls but your game doesn’t, you are doing something wrong (most likely the wrong node)

1 Like

in SS , converting car3.scene to j3o not successful and spent about 15min without any result …

I know that there is a problem but I dont know where is it …
in my 3d designing ?
in my code?
in model conversion from ogre to j3o or in blend to j3o?
I dont know why…

If you Open the j3o and it works the Problem is your code. You might have the wrong node, Maybe a typo in its name.
Ensure to Close the sdk and reopen the j3o, that way I can rule out saving issues.

The Endless Loop is most likely a bug in the blenderloader which is why ss doesnt work either.

How do you acquire those Controls?
Oh and btw: xbuf wont have animation issues. Blender Loader has to implement any blender algorithm, where xbuf just bakes them.

1 Like

First question -how big is your blend file and textures - if you packed textures in one 25MB file it is usually take much more time to convert than 2MB file.

If it’s playing in the scene composer and not in game then its working but you probably just need to reference the correct child geometry of your node, the one that contains the Skeleton Control and Animation control in the scene composer. You could also try using a null checkon your animation control like this and you’ll know if its the control glitching out or if you aren’t referencing it right and its null.

Node node = (Node) app.getAssetManager().loadModel("Models/Armitures/tiffany1h.j3o");
Animation control = armiture.getChild("Cube.001-ogremesh").getControl(AnimControl.class);

if(control == null){
     System.out.println(" control is null ");