Copy entire project to new machine ignoring android New sdk path?

Hi monkeys

I’ve copies my entire project to a new machine, and have the android sdk installed on a different path.

Netbeans See’s the new path, and I can bring up the Android Test Configuration Utility from within it.

But when I try to build/deploy the project to my plugged in device, it’s still referencing the path from my other machine.

poking around the configs, and doing search I’m not seeing the old path referenced anywhere…any pointers?


some progress, turns out defines sdk.dir, which was referencing the old path

I have updated that, but now the android build.xml is complaining about: …mobileMANIFEST.MF

which also didn’t exist on the old machine…

I tried removing android support from the project then adding it back in…that causes a bunch off errors…

long story short…

I ended up creating a new project and just copying the sources/assets back into the new project.

One thing of note:

The new project also complained about the missing MANIFEST.MF…

I used the tip from ironmars from the thread:

and just copied the existing .xml file to MANIFEST.MF

the project now builds…and attempts to deploy…but…(I think I may have an issue with this laptop/google-usb drivers)…device is never detected…by the sdk…(stuck in waiting for device to be ready).

fyi: lenovo t61p/asus prime 300.

time to poke around the android forums…

wow…ok that last part turned out be a nightmare from hell…and lots of googling…

Apparently…I needed to: (note: I already had the google adb/usb driver installed)…

0) Uninstall google usb-driver

  1. Install the Asus Sync tool
  2. That results in ADB is out of date error. (but apparently installed compatible usb drivers)
  3. Hack, the adb.exe (delete it) provided by asus, and copy googles ADB.exe into the asus sync directory).

    finally…it works now now on the new machine.

    never needed to do all that on my desktop…(guess I had an older version the android sdk/firmware back then…that didn’t need this hack).

    Anyways hopefully that will be of use to someone else.

    (and yes I can still plug it back into my desktop and all good).

1 Like

The location of the android sdk for the jME SDK is stored under “mobile” in the app preferences. Glad you found out whats the issue for you.