"Could not find the main class" (solved)

I upgraded jME2 now, but there's something fishy somewhere… I updated my build path to …/windows instead of …/win32 and the tests in the jmetest package run just fine. However, my own project does not. I get the "Could not find the main class: … Program will exit." jME2 is included in my project's build path.

java -version produces this output:

java version "1.6.0_11"
Java(TM) SE Runtime Environment (build 1.6.0_11-b03)
Java HotSpot(TM) Client VM (build 11.0-b16, mixed mode, sharing)

I'm running Vista 32-bit. I have no idea why this happens when the jME-tests run..  ://

If the test run fine, so should your project.

Did you do a full rebuild?

If you want, you can also use the 2.0 branch where such surprises don’t happen.

I did a full rebuild, but I get the same error. Gonna try the 2.0 branch you linked.

Hmm thats strange.

How do you exactly start your app? in eclipse or another ide, or from command line?

I'm sure you verified that the class containing the main() method is really in your class path.