Cubes Rendering Artifacts

Using the Cubes Framework, I am noticing that there are a lot of artifacts with the cubes that are generated. See this: What can I do to fix this? (All the white lines). I have tried using anti aliasing, but that doesn’t seem to solve the problem. It looks more like its a problem with where the textures connect together. (Like there is a seam between the textures). Does anyone know how to fix this?

Its caused by mipmapping. Have you tried playing with the min and mag filter on the material? Or added anistropic filtering?

Most likely the coordinate Z floats in the values ​​at the vertices.

I tried Anistropic filtering, and that didn’t change anything. What method is used on the material for mipmapping? I haven’t worked with that yet.

I see what you are saying? Why just that axis? Is there a way to fix this?

Need to make sure that the problem in this, How far are you from the center of the stage?

Very close. Between 0 and 100 world units away.

But then the problem is not this. Do you use vertical synchronization?

You mean VSync in the settings correct? If so, then yes. It doesn’t make a difference.

Here is an interesting artifact: This is a mipmapping error right? I thought this system was enabled by default, however, perhaps it needs fine tuning as mentioned before? How do I do this?

This is called moire pattern.

Interiesting. How do I fix it? Is it even possible to fix?

material.setMinFilter and material.setMagFilter should help, but ultimately you need to provide mipmap levels. Its a common issue with many workarounds.

I guess that you moved your scene far away and simply went out of screen’s resolution. You can try to use DoF filter and blur everything that is far away from you (blind shot).

First of all - read about it, understand why moire appears.

This doesn’t seem to fix the issue properly. Now since I am using the framework, is it possible that the code is merging all blocks along the same axis into the same mesh? Would this explain why this is only happening along one axis? If so, do you know of any other fixes?

You have a bunch of objects overlapping.

No one will be able to debug your code because we can’t see it.