Cvs help

hey everyone, I'm just starting to get into game programming and someone suggested learning game engines so this will be my first attempt to learn how to use one. I'm using the getting started page as a reference to install. Everything so far has worked fine until the cvs portion. I should mention that this is the first time I've ever seen cvs and didn't even know it existed.  Anyway I opened Admin–Command line and put this in-- cvs -d :pserver:[guest] login then pserver for the pasword entry that comes up. Then the window closes and I get a exited 1 status. Can someone please tell me what I am doing wrong :?

hello dr. spud, im not sure the answer to your question but I can tell you if you use eclipse its quite easy to use cvs from eclipse

thx Ill try it… to update my previous post I tried something else I entered cvs -d login (this time withoutthe brackets around guest)

and entered it in the shell instead of the command prompt under Admin. This is what I got…

Logging in to

cvs [login aborted]: guest: no such user

Fatal error, aborting.

Try this instead:

cvs -d login

followed by

cvs -d checkout jme

thx ya'll I got it to work. Now im just trying to figure out why I have compile errors.

heres what happens when I try to compile…

C:jme>Ant dist-all

Buildfile: build.xml

Overriding previous definition of reference to classpath


    [echo] jmeKeyStore


    [javac] Compiling 510 source files to C:jmebuild

    [javac] javac: invalid target release: 1.5

    [javac] Usage: javac <options> <source files>

    [javac] where possible options include:

    [javac]  -g                        Generate all debugging info

    [javac]  -g:none                  Generate no debugging info

    [javac]  -g:{lines,vars,source}    Generate only some debugging info

    [javac]  -nowarn                  Generate no warnings

    [javac]  -verbose                  Output messages about what the compiler

is doing

    [javac]  -deprecation              Output source locations where deprecated

APIs are used

    [javac]  -classpath <path>        Specify where to find user class files

    [javac]  -sourcepath <path>        Specify where to find input source files

    [javac]  -bootclasspath <path>    Override location of bootstrap class fil


    [javac]  -extdirs <dirs>          Override location of installed extension


    [javac]  -d <directory>            Specify where to place generated class f


    [javac]  -encoding <encoding>      Specify character encoding used by sourc

e files

    [javac]  -source <release>        Provide source compatibility with specif

ied release

    [javac]  -target <release>        Generate class files for specific VM ver


    [javac]  -help                    Print a synopsis of standard options


C:jmebuild.xml:50: Compile failed; see the compiler error output for details.

Looks like you're still working with Java 1.4? You need the 1.5 SDK for jME.

:smiley: :smiley: :smiley: :smiley: :smiley: Now I feel dumb thx for your help everyone. I think I got it, Now the fun can start…