Debug locks Eclipse and computer

Hi, I’m running jme in Eclipse on linux.
It has happened a few times that while debugging a running jme application,
Eclipse locks up to the point that the only way to get out of it is a forced shutdown of the computer.
I assume that I get caught in a tight loop within jme…
( I don’t have any issues while debugging other Swing applicaitons for example )

Anybody had any similar issues and had a solution for it ?

Thanks and regards

I use the (Netbeans-based) SDK, not Eclipse. However, I have a similar issue on Linux.

Stopping a JME application with a debugger often causes the mouse to freeze. Usually I’m able to recover by using keyboard shortcuts, without forcing a shutdown.

In the situation you’re describing, are both the mouse and keyboard non-responsive?

Yes, worst case is when both mouse and keyboard are non-responsive,
then computer shutdown is only way out.

I’ve had other times when I get stuck, but somehow still manage to type at the breakpoint, and hotswap some bogus code, which triggers a runtime exception and then the jme process gets killed.

@sgold you also have the issue on Linux with the Netbeans-based SDK ?

Yes, v3.2.4-stable-sdk1 to be precise, but only the mouse is affected.

Maybe I should switch to the SDK,
there is apparently already 3.3 release version.

Thanks for your answers
and your work of course,
much appreciated !

I use IDEA and have never had that problem.

1 Like

@tlf30 just to make sure, you are working on Linux right ?

I work in both linux (fedora and ubuntu) and in Windows.

1 Like

I also use eclipse and linux and this doesn’t happen to me.

I do however see the same issue @sgold describes, the app suspends on a debug breakpoint and eclipse tries to gain focus but the mouse is not responsive so I have to fix it by switching to a different workspace (or whatever the window manager calls them) using keyboard shortcuts and then back.

What DE or WM do you use? have you tried using the shortcuts to switch window or workspace. You can use the old Ctrl-Alt-F1/F7 trick, maybe that helps.

2 Likes

I’m using Ubuntu 20.04.3 LTS
desktop env: xfce 4.14
window manager: xfwm4

For the mouse, look for XF86Ungrab, I think it was something to set to X11 each session and then a keybind to use it.

At best, it should be related to lwjgl2 vs lwjgl3, but it’s more so the mouse cursor lock of those. As a “workaround” you can probably disable capturing the mouse in jME using the one method on the inputManager.

Typing should never not work, and especially something global like xuan’s Terminal Shortcuts should even work when half the DE is already dying, at least it does for me.

Since this is kinda some DE (or even X11) behavior, we can’t do much, maybe the problem is solved with Wayland.

Edit: See here for how to do that and also why it behaves that way in the first place (bypassing screensavers)

2 Likes

I just had the issue again, but this time without Eclipse.
Running linux executable from here Release 8th release for alpha testing (1.0.0-alpha.8) · stephengold/Maud · GitHub

Mouse and keyboard locked.

Got out of the lock by
Ctrl-Alt-F1 , then kill Maud process from command line and back to desktop with Ctrl-Alt-F7
( as @xuan suggested )