of CVS code missing jmex packages

Hi all.

I built jME in Eclipse from CVS and just wondered why there aren't the jmex packages in the JavaDoc loacated in in targets-directory.

How can I get the complete up-to-date JavaDoc?

Greets Av

There's an ant task ("doc") for JavaDoc. It'll put the docs /data/doc.

There's… ehm… a few warnings during build though.

Hm k,

I did an Ant Built… with the only option doc.

Got following exception: …build.xml:95: Javadoc failed: CreateProcess: javadoc.exe -d F:EclipseWorkspacejmedatadoc -use -package -windowtitle "jME API" -classpath D:Eclipsepluginsorg.apache.ant_1.6.5libant.jar;D:Eclipsepluginsorg.apache.ant_1.6.5libant-antlr.jar;D:Eclipsepluginsorg.apache.ant_1.6.5libant-apache-bcel.jar;







Make sure you use a JDK for your project, and not a JRE (which Eclipse picks by default).

Do you mean as library in the buildpath of the project, or where exactly. Sorry, for maybe stupid questions, but i'm relativly new to java and eclipse. And very new to jME and 3D-graphics :).

Window -> prefs -> Java -> installed JREs

Add the SDK there, and make it the default.

Ah k, allright.

But it doesnt help. Still get the same exception.

Ant Building jme itself made no problems by the way.

As you can see it can't find javadoc.exe. Try putting it on the PATH

K, solved the problem. I think it was/is in path, cause I have a JAVA_HOME variable.

Although I made the JDK the default, following made it:

In the Ant build… dialog i changed under the JRE tab, the JRE from default workspace explicitly to JDK and it compiles.

I also restarted eclipse after I changed the default JRE into the JDK in the preferences before. Dont know why he didnt take it.

Thx for your help.

Greets Av