Early alpha of my game: Abyss of the Void

Hi, I decided to upload a very early version of my current project.

It is only the first area of the game and has no sound. Only about 5 min of gameplay, but the core of the game is there.
I plan to add more areas to explore and some enemies to fight.

I’m developing it using my own level editor and tools I posted here: Shooter game demo

While doing this level I wrote down all the bugs and pain points I found, so now I will take a break from the game itself and change hat from level designer back to programmer. So I can have a better tool going forward.
And that’s the main purpose of this game project, I want to validate and iterate my level editor and scripting framework.

If someone wants to give it a try I would like to know your thoughts.
I only tested on my computer and a few friends’, I’d like to hear how it works (it might not even run or crash in humiliating ways :stuck_out_tongue:)

Cheers!

15 Likes

Nice pics. Can you post a video of the game play?

Nice! I’ve given it a go. No crashes and I got to the point where I had found the medical bed (is that as far as it goes for now?).

I liked the intro very much, thats nice. And the game itself was intuitive, I didn’t find myself stuck at any point.

I found that the mouse movement was too responsive, I’d often found myself doing a 180 degree turn accidentally (I’m assuming in a final game that would be a setting though).

May not be an issue but I noticed this being spammed into the logs for me

[INFO] [akkaDeadLetter][05/26/2021 09:27:12.597] [Game-akka.actor.default-dispatcher-5] [akka://Game/user/cryo/entities/entity-58] Message [com.stovokor.core.actor.TellPosition] to Actor[akka://Game/user/cryo/entities/entity-58#-1663802911] was not delivered. [1] dead letters encountered. If this is not an expected behavior then Actor[akka://Game/user/cryo/entities/entity-58#-1663802911] may have terminated unexpectedly. This logging can be turned off or adjusted with configuration settings 'akka.log-dead-letters' and 'akka.log-dead-letters-during-shutdown'.

Btw, is the logs intentionally open along with the game for testing purposes when launched from the bat? If not changing the bat to

start bin\javaw.exe -jar app\abyss-of-the-void.jar

will just start the game without leaving the logs console in the background

5 Likes

Thank you very much! this is great feedback.

There’s a little more to go. If you use the medical bed your health will be restored to 100%.
That lets you do something you couldn’t do before (there’s a tip in one of the logs :wink: :parachute:).

Good to know, I might lower the sensibility then. For me it feels fine, but yes there should be a setting at some point.

Yes, that’s normal I get the same, never bothered to clean it up.
I get about 10 of those at the start and then sometimes when entities are removed (e.g. picking up an item).
That happens because I’ve been sloppy at handling some edge cases.

That’s a great tip! I don’t have a windows installation to test and I haven’t used it in 15 years so guessed the command to run it. I will upload a new build with this fix :smiley:

1 Like

Ah I see. I don’t think I would have realised that without the hint, I had already tried jumping down the hole and been killed by it so didn’t think to retry.

Couple of issues I found, I randomly died here:

And I noticed if you run and use the wrench at the same time it harms the player

I finally ended up teleported here

there’s a tip in one of the logs

O! I hadn’t realised you could click into the logs for more detail. I thought they were just strangely short notes

3 Likes

Aha! Good catch. I just tried and was able to kill myself with the wrench.
Were you using the wench in the ventilation shaft as well?

Yes, that’s the end for now. That room is just a placeholder.

Yes, it’s gonna be an important part of the game to read the logs to reveal the story and get useful info. I need to make it more apparent when elements are clickable.
Funny how one can overlook those details and assume everyone will magically just know where to click :smiley:

1 Like

I think that’s very likely, yes

I did not want to at first since I think if you see the video there’s really not much point of playing the game and I wont be getting much feedback that way.
For those that do not intent do download it but want to see the gameplay, here you go: :slight_smile:

9 Likes

Nice i tried it so far, assets are great, idea similar to Deus EX, keep going !

But, may be some suggestions for the gameplay :

  • Add crouch ability for very narrow mines.
  • Avoid Looping things as possible, like making the medical or surgical unit room door when opened, never closes & doesn’t loop again the medication.
  • Making the door openable without even taking the medication, it will benefit the gameplay, if you add enemies or NPCs for this first level…

Also, I have noticed something, when i pickup the wrench & starts punching the walls like any crazy gamer, the life points of the player decreases with each hit to the wall, is it a part of game tactics or bug or wip thing ?

I know this is a demo, but just what i noticed…

Please post & keep updating the game, it may have even inspiring ideas for us, like how should we organize the game, what ideas to put when doing game level building,…etc.

Good Luck !

Deus EX, Hitman, AC’s do this as a stable dialog outside the more TAB dialog, the logs dialog has also sound plugins with different languages, you may try separating the dialogs in the form of independent panel on the top left corner, so the players are keeping themselves consistent with the storyline.

Thanks Pavl for testing and your feedback.
I agree crouching would be good, I wanted to make the ventilation shafts smaller but I couldn’t because I was missing the ability to crouch. So I will probably add it later, it just wasn’t a priority at that time.

I’m not sure I follow.
My idea was when you exit the cryo room and walk through the hall with all the doors, the Infirmary door says “this door opens elsewhere” so that seeds an objective in the player’s mind. After finding the way in thought the ventilation shaft, the door can be opened from the inside, so there’s no need go back through the long path (to avoid boring repetition).
The door can still be open without getting the health, there’s no such limitation today.

I just replayed that part and I realize the door closes back on you and stays locked, this is a bug and should either stay open or unlocked after you’ve been inside the infirmary. No point of forcing the player to redo the ventilation shaft again (that “puzzle” is solved).

Definitely a bug :smiley:

I see what you mean, but I’m not sure how well would that work without actual voices reading the text (wont happen). My inspiration was more like the first System shock (or Marathon) where you have to stop playing, open a computer and read (and hear in ss1) the text. I think it adds to the immersion and adds tension (enemies can catch you off guard) this way. Also it’s not so “in the face” if you don’t want to read the logs, no problem just don’t open the computer. But I definitely plan to have some clear indication that there’s new content to read (also indicate what’s new and old), currently when you pickup a cassette nothing happens that urges you to tab into the computer.

Thanks!

2 Likes

Some games, make only notification pop-ups & different tones on different events being displayed in the logs, you can display an icon that sends soundful notifications to users to trigger them to open the logs panel for important announcements.

2 Likes

Very good, although I haven’t been to the community for a while, I am glad to see your work. :+1: :+1: :+1: :+1: :+1: :+1:

1 Like

Looks very “Half-Life” style

1 Like