Effect doesn't work at school

My particle effects don’t work at school, but they work at any other computer that I tested them on. And some of the computers that I tested particle effects on were worse than the school computers, but it still worked on them. The school computers are pretty new, they have openGL 2.0 and dual-core, but it still gets errors when I try to use them. How would I fix this?

Well…from this input, the only thing I can say is “Don’t play games at school”…

If you want more constructive help, consider posting the error log you have on the school’s computer, maybe the graphic card used there…and maybe if you can, try to upgrade the drivers on this machine.

nehon said:
Well...from this input, the only thing I can say is "Don't play games at school"...

Good one man ... :D

My particle effects don’t work at school ...

2 things can caused error in your effects in the specific computer ...

1- "The file path" of the system maybe???
2- The configuration of the computer in school , not writable , don't have permission , virus ... and may be the last but most important the required software or hardware like @nehon said...

Let us see the log :p , it's help !!!!

I have had issues with particles on one of my computers, it is due to faulty drivers. Since you probably don’t have administrator privileges on your school computers, updating the drivers is not an option.

First I suggest you post the log, as it might reveal the (obvious) issue.

Otherwise, you can try not using point sprites for the particles. In the TestExplosionEffect, some of the particle emitters are created with the type “Points” while others are with “Triangles”. Using “Triangles” is generally more compatible and might work better for older drivers/GPUs.

Here’s the error log:

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]

java.lang.UnsupportedOperationException: No default technique on material ‘Point Sprite’

is supported by the video hardware. The caps [GLSL120] are required.

Well that’s what Momoko_Fan was talking about, it seems the graphic card does not support point sprites, try to use triangles

I was using triangles, I tried both and it doesn’t work. The school just bought these computers >.>

I noticed the particle shader requires GLSL 1.2 by default, I fixed it in SVN now.

can i please have the link for the jme jar files, the latest svn?



Go to the bottom where the latest release is posted