Error message upon opening

Hey, im running linux ubuntu 11.04 and i have downloaded and installed NetBeans 6.9, JavaMonkeySDK ( and i also have both openJDK and IcedTea installed but i use Sun’s java packages… im also pretty sure i have the JDK… I download all this stuff today (exept java) and tried to run the JMESDK but upon opening i get the error message The JDK is missing and required to run some NetBeans modules please use the --jdkhome commandline option-… same error upon opening netbeans, i can continue regardless but when i create a new basic game project not much happens and i can’t create files, like in the youtube videos, please could somebody help me out?

P.S in the commandline i have used netbeans --jdkhome /jdkpath and it opens netbeans fine…

Make sure you installed the jmp before installing the sun jdk…

Make a clean install by removing the jmp and the sun jdk package and re-installing them again.


sudo apt-get remove --purge sun-java6-jdk

sudo apt-get install sun-java6-jdk


What is your issue? Just enter the jdk location manually for the jME SDK as well, like its described in the error message… And normally the JDK should be installed first, then the SDK.

Thanks glau im no longer getting the error message, but in the SDK i cant really do anything - there is not a file explorer like in the tutorials and video tutorials, only this my projects folders which always says no projects open - i have made several projects but when i go to open project i select one of my projects - basicgame but it just opens the directory, and when its selected it says project name <unrecognized project; missing plugin?> also it said i had two updates so i updated and restarted, then it said i had 11 updates so i installed those too, not much difference - heres a screenshot

also in NetBeans (ive always used eclipse up until now) i cant make a new project, a similar issue but when i try to make a project, in the tutorials it says java apllication, but in my netbeans, i only have two folders, one is samples and has two kinds of files inside the other has a different kind but no java application. I don’t really care much for netbeans but just adding this as it may be part of the problem here.

Try to do what @normen said, by setting the jdk path manually for the jmp via "settings

>java plataforms---->add plataform" (or something like that).

ok ill have a go thanks

Theres is no settings…

:|. So there’s nothing in your jmp…Did you already try to remove jmp and re-install it again?

ive removed it twice now, im installing it for the third time now, i have once again removed JDK… ill install it when the JMP SDK install is complete

wait when you say JMP are you talking about the SDK or what?

javagame said:
wait when you say JMP are you talking about the SDK or what?

If your drag your mouse about "jmp" you will see something like : "The jMonkeyPlatafomr, a full-fledged IDE with....." ;).
Yes, I did mean to the SDK.

No, sorry, but for now i have no idea about it, i’m going to get back when i get an idea…

done a clean install and it works like a charm, thanks!

glad it worked :).