Error: Pixel format not accelerated


A couple of days ago I found out about the jMonkeyEngine and decided to download the jMonkeyPlatform. Unfortunately, I got some trouble with the SceneViewer in jMonkeyPlatform Alpha-3. When it loads it hangs at 14% and gives the error “Pixel format not acceletared”. Updating both Java and my graphics driver doesn’t change a thing.

Now I happened to find a game called “Minecraft” which also uses the LWJGL. The browser applet version of the game gave me the exact same error. Although my graphics card should be able to support OpenGL 3.2, I circumvented this problem by allowing “software OpenGL”, by setting the following parameter in the Java Runtime Environment Settings (in the Java Control Panel):


However, this does not solve the problem for jMonkeyPlatform. Therefore my question: is there a way to allow software OpenGL in jMonkeyPlatform?

It is a driver issue.

If you’re on windows, do NOT use Windows Update to get the latest drivers, use the manufacturer’s website, or even preferably, nVidia or ATI/AMD website (or Intel or SiS depending).

What kind of video card you’ve got? Is this on a laptop, desktop? Etc.

Thank you for your reply.

Well I already installed the latest version of the driver from the ATI/AMD website, so would that mean that they just didn’t implement it in the driver (although the card itself should support it)?

I got a desktop machine with an ATI Radeon HD 4600 Series card, running Windows XP.

openGL capabilities is removed from the drivers coming from Windows Update, but AMD/ATI’s site definitively offers openGL in their drivers.

You can check openGL support by using the following software:

I have never used it, but it should tell you what version of openGL your card support if the corresponding drivers are installed. You might also find that information in the Catalyst control panel, but having not used ATI stuff for years, I can’t say if the info is there or not.

Hopefully that’ll help.

Hmm, then my driver should be OK. The program you linked to doesn’t work, but the Catalyst Control Center says that the OpenGL version is so that should be good too. I wonder if this error really is so OpenGL specific?

Thanks for your help :slight_smile:

Edit: since 4.1 is the latest version of OpenGL I don’t think the number above has anything to do with that… but at least it’s mentioned in the Control Center :stuck_out_tongue:

Run dxdiag and see if you have any error there.

WindowKey+R then type dxdiag.

Nope no errors…

Okey I found another program at another forum at

It is the OpenGL Extensions Viewer. This program tells me that the Renderer is “GDI Generic” (which is the main problem according to that topic) and that the OpenGL version is 1.1. It seems to be a problem related to Windows, which somehow uses an old OpenGL driver. This may have to do with the onboard graphics chip and although the solution provided in that topic should make Windows unaware of the onboard chip, it is no solution for me.

I deleted all the graphics related keys from the registry as suggested, but I think that Windows is still using the ASUS (which is my motherboard) OpenGL driver. Does anyone know how else to make Windows use the OpenGL driver that comes with the ATI graphics card driver?

What I would do is uninstall all graphic drivers from your computer then turn off the computer. Don’t forget to use a driver cleaner. It’s important to remove all traces. When restarting, go into the BIOS and disable the onboard video.

Then install the latest drivers.

That should work.

1 Like

This is gonna sound REAL stupid but I never thought of looking into the Windows Software panel… It turned out that the “ASUS Enhanced Display Driver” could be easily removed in there, after which the OpenGL Extensions Viewer saw my ATI card with OpenGL version 3.3!! :roll: I did however remove the ASUS registry keys before but apparently that’s not enough.

jMonkeyPlatform runs fine now! Thanks for your help!! :wink:

No probs. Happy you can now run jMP. :slight_smile:

Deleting registry keys should be the last attempt after everything has been done to ensure that all traces have been removed of an unwanted software, but this will not remove stray files. :slight_smile:

How does one get into the Java Runtime Environment settings and add new script? I’m having the exact same problem, except regarding Minecraft
Hope someone responds since this is a 7 year old thread
Assuming this will work for other OpenGL software that I need, as well as minecraft, I would like to try the method

If I understand the question correctly, you don’t. I take it you somehow want to hook into the JRE so that you can force minecraft to use some command line setting?

Modern Minecraft is not launched that way. Your best bet to get Minecraft support is through Minecraft support.

All they tell me to do is update my drivers to the latest. I have the latest drivers, and nothing works. If you look at the beginning post, the entered the following parameter;
into Java Runtime Environment Settings. I want to know how to do that… I’ve made many searches with no success.

Step 1: learn to be a hacker
Step 2: hack minecraft to start differently than it does
Step 3: take the hacked up minecraft and start it from the command line with that option

Might be quicker/easier to get a machine that can run Minecraft.

Other than that, folks who actually play minecraft and have dealt with this problem more recently than 7 years ago (when Minecraft started from the command line) will be more help than any single person on this jMonkeyEngine forum.

What the hell this has to do with jmonkey is another story, but here is your answer. In regard to your driver problems, you need to NOT use the windows update drivers that are installed automatically and use the nVidia website to download the latest drivers.

1 Like