Error when creating an Android project in the SDK


I’m having trouble with creating an Android project in the SDK. When I enable Android development in the preferences I get the following error in the log:

Checking extension…

No extension file mobile-impl.xml found

Creating extension file mobile-impl.xml

Creating extension mobile

Error: G:DevelopmentGameDevjMPAndroidTestmobile is not a valid project (AndroidManifest.xml not found).

I have checked the mobile folder and it’s empty so it’s correct that it can’t find the AndroidManifest.xml.

I’m using the nightly build from the SDK.

Thanks in advance.


Try to clean / build your project :). And make sure the android libraly is in your project’s classpath.

The android library does not have to be in the classpath. Make sure you have a valid android sdk set, are you sure you did not ignore a filechooser popup to set the sdk path?

I have set these path’s in the Options:

Mobile: F:Program Files (x86)Androidandroid-sdk

Miscellanecous->Android: F:\\\\Program Files (x86)\\\\Android\\\\android-sdk

When I press the “Run Android Target Configuration Utility” the Android SDK Manager starts.

Is there a log file where I can find more information about what’s going wrong ?

Yeah the “output window”

I have created the basic game template again and enabled the Android support. It works now, but I don’t know why it didn’t worked previously.

Thanks for your help anyway. :slight_smile:

I have found what it was with my own projects. I had used the “-” character instead of the “_” character in the Title in the project properties.

1 Like