Fixed Morph anim shader compilation in android

Hi,

I’ve fixed the MorphAnim.glsllib to successfully compile on android. It was commented on closed issue https://github.com/jMonkeyEngine/jmonkeyengine/issues/635 but was left for a new issue.

The test jme3test/model/anim/TestMorph now runs as expected.

Also I’ve fixed an error that GLRenderer tried to enable GL_VERTEX_PROGRAM_POINT_SIZE which is not avaiable in gles. If running the android examples in debug mode you would get a 1280 error for any test.

I’ll update the post once I’ve created the PR

EDIT: PR link --> https://github.com/jMonkeyEngine/jmonkeyengine/pull/1221

7 Likes

good job, i didnt even know it dont work on Android.

I hope your PR will not break desktop versions :slight_smile:

Of course! I’ve tried the change in both Android and desktop :wink:

3 Likes

Thanks

@joliver82

seems like Desktop shader require lvalue / pointer of variable passed as normal, while you removed it, then it break. Not sure why android allow it, but please add this little fix for Desktop, thanks :slight_smile:

Sure! I’ll have a look at it just after my vacations :wink: although it’s weird because I tested it on desktop also before PR

1 Like

probably because your video card was more clever to avoid this error :slight_smile:

not that clever, it’s an intel card :sweat_smile: