Full screen in Windows 10 not filling entire screen

One of my testers report that full screen mode does not actually fill their whole screen in my JME 3.0 game. (using a smaller, non-native resolution option)
He is using Windows 10, for which I cannot manually test currently, and I’m unable to reproduce it on my Windows 7 system. I did not get a response to this yet, but I believe he’s not using DPI scaling judging by a screenshot he sent me.
Instead of stretching to fit, the game is placed in the top left corner. I think I’ve heard that windows 10 does not support dedicated full screen mode anymore but I wasn’t sure if that only applied to games from the microsoft store.

It occured to me that my tester might have accidentally picked borderless windowed mode from my custom launcher, but he actually reported this multiple times now so I’d like to ask around before pointing any fingers.
There are no ingame options that switch between fullscreen and windowed mode, leaving it only to the launcher, which looks clean to me.

I had another friend try the game on his win 10 laptop but it worked fine for him, even created black bars on the side to fill in the aspect ratio difference, instead of stretching.

I’ll try to gather more information from him but in the mean time, I’d like to know if this is a recognized issue at all.
Any help would be greatly appreciated!

Is there any chance that the given resolution (1024x768) might not be fullscreen-compatible on his device? I can’t remember the last time I saw a PC with resolutions that weren’t fullscreen capable.

The only way to know is a basic test case to isolate the potential bug and see if it persists.

Maybe not only him:


I searched this last time when I have problems with this (win8) - is he try your game with all programs switched off (skype, autohotkeys, calc, notepad - all)? With locked/unlocked taskbar? Has he taskbar at the bottom?

It’s not just the taskbar, I’d share the screenshot but it contains personal information in the background so I can’t.

It is acting as if the game was in borderless windowed mode, so it’s in the top left of the screen, and the remaining areas to the right and bottom are visible (about 100-200 pixels), because he was trying to run it in a resolution below his desktop res.

For now I’ve sent him a new version which prints out some information about available resolutions and whether they support fullscreen mode, plus the active res along with the “isFullscreen()” value.

Edit/blur it out?

Does the system have more than one monitor? And if so, what is the second screen doing? Mirror/extend/etc.

I have this setup (below) on Windows 10 (it might be an upgrade from another version of Windows - something for you to check on, also) and it works fine either way. I have two monitors and it works properly on both.

public class Asteroid3D extends SimpleApplication {
        public static void main(String[] args) {
            Asteroid3D app = new Asteroid3D();
    		AppSettings settings = new AppSettings(true);
    		/*settings.setResolution(300 * 4, 200 * 3);*/
    		settings.setResolution(1920, 1080);
    		app.setShowSettings(true);//turn on/off settings dialog box

So, my app only goes into real fullscreen mode in 1920, 1080 res mode. Turning on the app.setShotSettings(true) will unset fullscreen mode if you pick the wrong res.
Oh, also, you know that, on a PC, Alt-Tab changes between programs and that Alt-Enter changes from windows mode to fullscreen modes (if the app is fullscreen capable). So, try Start, All Apps, Windows System, Command Prompt (for a DOS box). Alt-Enter will toggle it into and out of fullscreen mode.

Edit: No, I don’t think JME will toggle in and out of full screen mode with Alt-Enter. But the DOS box will and some games will.