Getting SimpleApplication Working with New Android Plugin

I am unable to successfully run the SimpleApplication program on my android device using the plugin. These are the steps I have taken to try and get this working:

Step 1: I have already installed the latest nightly builds of the Android plugins and libraries:

Step 2: I clicked the “Enable Android Deployment” checkbox and restarted the application based on these instructions:

Step 3: Upon restart, I am able to successfully build the application. However, under the android files, one will notice all the unresolved libraries. Please note that I was still able to build the application below:

Step 4: However, when I run it on my Samsung Captivate, I receive an error (see below). I suspect that the AndroidHarness library is not working correctly, because I am able to successfully run all the tests in Jme3 Beta1 Android Demo on this device:

In order to try and resolve this, I have done the following:

To try and get those libraries resolved, I added the libraries (jme3-android and google’s corresponding 2.2 android.jar) to build path. You will notice that I no longer get the red lines underneath the libraries, however it is unable to compile at this point:

Can anyone please give me any other ideas I can try to get this working?

As I (and the manual) told you already you DO NOT need to add the android libraries somehow and can ignore the errors in the MainActivity file. The application obviously works when it can complain about the device not supporting OpenGLES. Install NBAndroid if you don’t like to see the falsely displayed errors. The test on the market uses the same way of using AndroidHarness to run the application.

I am getting the same error message (Open gl es 2 is not supported) when I try to run the apk build with jmonkey on my Nexus (2.3.6).

In the past when I build it manualy in eclipse it did work…

I don’t understanf how to solve this issue ?

I was able to get it working by changing the ConfigType.BEST to ConfigType.LEGACY. Give that a shot.

yes, Change ConfigType.BEST to ConfigType.LEGACY, It works