Getting started

I wanted to run tutorials in eclipse, how should I proceed further in running any J monkey code? I am new to jmonkey…

How can I successfully compile and run Jmonkey code in eclipse?

refer to this

I am facing troubles in the 4th step.


Actually that guide is a tad old. For a newer guide to installing jME 2.0 on Eclipse, check out this page.

After you manage to chew through that, just start looking into the example programs iin the com.jmetest package of the source.

Hey Mindgamer,

I have already set that thing up , and then can you elaborate upon how to get examples working?

Well… if you have the jme project set up as described… then you just choose the test class you want to run… right-click on the file and choose Run as… Application… and it starts up.

In the friendliest possible way… perhaps also check out these to start out… before you start on a game.

When I run any tutorial from jme2physics, it gives me "LAUNCH ERROR"  which says "Editor does not contain main type"

Druffy said:

When I run any tutorial from jme2physics, it gives me "LAUNCH ERROR"  which says "Editor does not contain main type"

Hi Druffy I got your message.  It's best everything is answered and questioned on the forums so people in the future can search for your issues.

OK you'll have to help me out, I don't know jmonkey very well.  I don't even know where the physics modules are. Which physics test file are you trying to run and where is it in the project?

Also do you have any compilation errors (which probably means linker error)?  Or just loads of warnings?

can you run the jME tests?

Ok Harsha,

I figured out its working now, I was also importing classpath in my project… thanks…

I imported one more project. And it seems classpath is getting affected. How do I proceed further in this case?

I really dunno why? none of those 8 tutorials are working, I did all those settings , setting up svn and all those stuff. It still gives me the same error of "Editor does not contain main type" , before some time it was working when i copy pasted that file in some other project. What can be the solution?

I’m not an eclipse user, but googling “Editor does not contain main type” yielded this thread as the first result.

You might be able to identify your problem with that.

Step 1

I think you're using the old physics engine with the new jme library, which won't work.  Use these.

Core-Dump said:

jme 2 versions:

Step 2
Assuming you have jme working, to get the physics lib working you need to tell eclipse where ode is on your system.  Go to your jmephysics project properties -> Java Build Path -> Libraries -> Expand odejava-jni.jar -> Select Native library location -> Edit -> Workspace -> "jME Physics 2/impl/ode/lib"

Step 3
The classes in tutorial/ aren't part of the source files for the project.  I just hacked the project files so they were in different places.  But I'm sure someone here who knows eclipse better than I do can fix this step better than I can.  Ideally a new revision should be made to the project files so this step doesn't exist. 

Yep JME is working for me, but when I try to run JME physics tutorials(8 in total), it does not show up anything and here is the whole message that I get,





2-Nov-2008 5:49:56 PM com.jme.system.PropertiesGameSettings load

WARNING: Could not load properties. Creating a new one.

2-Nov-2008 5:49:57 PM class com.jmetest.physicstut.Lesson1 start()

SEVERE: Exception in game loop

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

        at java.lang.ClassLoader.loadLibrary(

        at java.lang.Runtime.loadLibrary0(

        at java.lang.System.loadLibrary(

        at org.lwjgl.Sys$

        at Method)

        at org.lwjgl.Sys.doLoadLibrary(

        at org.lwjgl.Sys.loadLibrary(

        at org.lwjgl.Sys.<clinit>(

        at org.lwjgl.opengl.Display.<clinit>(

        at com.jme.system.lwjgl.LWJGLPropertiesDialog$



        at com.jmetest.physicstut.Lesson1.main(

BUILD SUCCESSFUL (total time: 3 seconds)

This time I am using Net beans and its working much more better than eclipse, in eclipse nothing was working , here atleast JME 2 is working.

Could anybody tell me how to fix it?

You need to link against your native lwjgl library. 

Do this if you're on windows:

Project Properties -> Java Build Path -> Libraries -> lwjgl.jar  (expand me) -> native library location -> jme/lib/lwjgl/native/win32

It's a simple change at the end if you're on another OS, just change the file path.