How do I export a model from 3ds max to mesh.xml files and skeleton.xml files?

Hey guys, I have a problem. I just want to export some Starcraft2 assets to mesh.xml files and skeleton.xml files to use them with jmonkey engine, but I dont know how. Ive install a 3ds max plug in witch help me to open M3 files(Starcraft2 assets format) and to import them in to the 3d studio max and all work great, now i need to export this assets to xml and i dont know how:( Ive install the OgreMax Scene Exporter but this export my models as

mesh files not as mesh.xml files.

Plese help!

Thank you and sorry for my poor english :wink:

You can use Ogre Command-line Tools found here : (see the bottom of the page)

You just drag and drop mesh file onto the right converter, you get the mesh.xml as output. It works the other way around too.

The ogre command line tools are included in the SDK, just copy the model to the assets folder and convert it there.

Well, I tried both ways. When i try to convert it with SDK i got a msg witch look like this “Error convertic filename com.jme3.asset.AssetNotFoundException: Models/filename.mesh.xml” and i don`t know how to use the console way…can you detail pls :frowning:

“Error convertic filename” is not an error the SDK outputs. Please describe in more detail what you do.

I open the jMonkeyEngine SDK, File, New Project, JME3-Basic Game, Next, Finish, then i copy my filles in Assets/Models, then Right click on my file filaname.mesh file and convert to jo3

And then what is the exact stack trace? If theres a warning sign in the lower right click that. What OS are you on?

I’m using Windos7 pro x64. Here is a video with what i need to do, and what happens when i try to convert this files:

Well, overall i need to import some SC2 assets and use it like in the HelloAnimation example

See the little warning sign in the lower right that appears at 2:20? Click it and post the content here, or maybe the content even tells you directly whats wrong.

do you mean this ?

com.jme3.asset.AssetNotFoundException: Models/ghost2.mesh.xml

at com.jme3.asset.DesktopAssetManager.loadAsset(

at com.jme3.asset.DesktopAssetManager.loadModel(

at com.jme3.asset.DesktopAssetManager.loadModel(

at com.jme3.gde.ogretools.OgreBinaryMeshDataObject.loadAsset(

[catch] at com.jme3.gde.core.assets.actions.ConvertModel$


Yeah. Apparently your mesh file references another mesh that you didn’t export.

So, how can i fix this? How can i get that mesh.xml file? pls help me, since 11 am i try to figure it out, now here is 6 pm…

Where is this ghost2 file?

@pengu said:
pls help me, since 11 am i try to figure it out, now here is 6 pm....

Hehe, cute ^^ I don't know, read the manual of the exporter I guess. Do you have a ghost2.mesh? If yes you might have to convert the mesh files manually using the command line tools (again they too have a manual) because the SDK doesn't convert linked models. Question is also why is it different files at all? You made a proper game compatible model or you just imported *some* model into ogre and try to export that?

The Ghost.m3 is in the starcraft 2 assets after you unpack the base.SC2Assets with MPQEditor(or any other program that can unpack this kind of files)

The ghost.mesh i`ve export it in the MyProjectAssetsModels

As i said, the model is not created by me. It is imported, into 3ds max and exported with OGRE

This issue is not how its created, the issue is how you are exporting it.

The point is, you also need to have ghost2.mesh file to open ghost.mesh. So, when you are exporting you need to have / export all of the dependencies.

You can open the xml file and investigate this by yourself.

Bottom line, you are exporting it wrong.

Ive just call it ghost2 when ive export it. I don`t think it is a dependencies problem

Thank you guys, problem solved, iamcreasy helped me

-.- Please say how. Else this two-page thread is completely wasted space, time and words.