I not fond the folder that name is "Common/MatDefs/Misc/"

Hey sir , I got your rts engine code , and compile it , but catch a exception , detail is : Material res = new Material(am, “Common/MatDefs/Misc/Unshaded.j3md”), Could you solve my problem ?

I will need more details to help.

Are you using an IDE like Eclipse or NetBean? if so, did you follow the setup guide to build the project?

Or maybe you are trying to run the project directly from Gradle at command line ("./gradlew run" on linux or “gradlew.bat run” on windows in the cloned repository directory)?

Great sir , thank you reply me so quickly! I use the Gradle directly and then use the ecliplse import the source , but this is wrong?

The project should run at least with gradle in command line. Does it work for you? if else could you paste the entire exception?

If it runs in command line, but not in eclipse, it is most likely the import thing that mess up. You may try to delete the project in Eclipse and re-import it with the gradle plugin as explained in the wiki I pasted earlier.

But first of all, try the command line.

The latest Gradle ? The project have a file that name is “gradle-wrapper.properties” , I found the verson from the gradle is “gradle-2.2-all” , should I update the version to the latest?

What exception?


The folder that name is “Common” is not exist in the project , the material is need some asset from this folder to initialize.

The exception is a NullReferenceException.

It’s always a good idea to get the latest version. I run it with version 3.7. Don’t remember about 2.2.

Also, please run the core project and not the exemple. I should delete the exemple project since it seems to be bugged.

The common directory is embedded into a library. You can’t see it anyway.

For future reference: exceptions are useless without a stack trace. Best to cut and paste right from the output because that doesn’t even look like a real exception.

Oh , great sir , I run the map editor very well , but I want run the game , I found some app that name is “Game”,“GameMutliplayer” , these project is not used?

What should I do to run the game from the OpenRTS ? I am a unity3d programmer , and now boss want to make a rtx game that like the WC2 , I want to reference your implemention . Thank sir!

This is very true !

Well for this one I admit it’s my fault :slight_smile: the project that @wyb314 tried to run is to be removed.

Please forget about all but Core. The exemples were implemented by a contributor that is not active anymore and I will delete them to avoid confusion. Core leads you to the map editing mode at first, but you can switch between modes with F1, F2 and F3 (explained in the readme for records).

Have fun and don’t forget the project is in standby for now, living a deep refactor in the underground.

Oh , my god , I hope sir do a great demo to testing the openRTS awesome , your project will help me a lot . Thank you!

Glad to hear it ^^ please give feedback and credit ^^