Icon missing on FilterPostProcesor files and New FilterPostProcesor wizard


The icon for FilterPostPRocesor files on asset folder is missing on 3.0 final SDK. Same with Empty FilterPostProcesor option on New File menu:

I fixed it:


# This patch file was generated by NetBeans IDE
# Following Index: paths are relative to: D:\java\SDK30final\3.0final\sdk\jme3-core
# This patch can be applied using context Tools: Patch action on respective folder.
# It uses platform neutral UTF-8 encoding and \n newlines.
# Above lines and this line are ignored by the patching process.
Index: src/com/jme3/gde/core/filters/FilterExplorerTopComponent.java
--- src/com/jme3/gde/core/filters/FilterExplorerTopComponent.java Base (BASE)
+++ src/com/jme3/gde/core/filters/FilterExplorerTopComponent.java Locally Modified (Based On LOCAL)
@@ -60,7 +60,7 @@
 @ConvertAsProperties(dtd = "-//com.jme3.gde.core.filters//FilterExplorer//EN",
 autostore = false)
 @TopComponent.Description(preferredID = "FilterExplorerTopComponent",
-iconBase = "com/jme3/gde/core/filters/icons/eye.gif",
+iconBase = "com/jme3/gde/core/icons/eye.gif",
 persistenceType = TopComponent.PERSISTENCE_ALWAYS)
 @TopComponent.Registration(mode = "navigator", openAtStartup = true)
 @ActionID(category = "Window", id = "com.jme3.gde.core.filters.FilterExplorerTopComponent")
Index: src/com/jme3/gde/core/layer.xml
--- src/com/jme3/gde/core/layer.xml Base (BASE)
+++ src/com/jme3/gde/core/layer.xml Locally Modified (Based On LOCAL)
@@ -202,7 +202,7 @@
                 <folder name="Factories">
                     <file name="FilterPostProcessorDataLoader.instance">
-                        <attr name="SystemFileSystem.icon" urlvalue="nbresloc:com/jme3/gde/core/filters/icons/eye.gif"/>
+                        <attr name="SystemFileSystem.icon" urlvalue="nbresloc:com/jme3/gde/core/icons/eye.gif"/>
                         <attr name="dataObjectClass" stringvalue="com.jme3.gde.core.assets.FilterDataObject"/>
                         <attr name="instanceCreate" methodvalue="org.openide.loaders.DataLoaderPool.factory"/>
                         <attr name="mimeType" stringvalue="application/jme3filterpostprocessor"/>

Thanks I’ll check that out

Actually it’s already fixed in master.

ok. I was working with source code from http://jmonkeyengine.googlecode.com/svn/branches/3.0final.

I will clone the code from github (GitHub - jMonkeyEngine/jmonkeyengine: A complete 3D game development suite written purely in Java.) and try to use pull request as you suggested on the other post (ColorRGBAPropertyEditor - a little improvement).

Thanks :wink:

which branch should I checkout out: 3.0 or master?
both of them use gradle?
which java version is required?

Edit: I’m having he following error when I checkout master branch:

I think it is related with java version but I’m not sure. any idea?

Edit 2: never mind. I fixed it setting java 1.8 on gradle setting for jmonkeyengine[root] project: