IDE accessing documentation is not working

I recently downloaded JME 3.6.1 and the bundled OpenJDK 17.0.9+9.

When I attempt to view javadocs for a class like Material, the ide throws an error that the internal web server could not be started, with a comment in the logs that reads

 When running on Java 9 or later you need to add "--add-opens=java.base/" to the JVM command line arguments to enable ObjectStream cache memory leak protection. Alternatively, you can suppress this warning by disabling ObjectStream class cache memory leak protection.

I’ve searched for settings to add this, both in NetBeans forums and JME forums, but can’t find any information. The “Internal Webserver” service does not appear to offer any form of configuration editing.

1 Like

Is this within the JMonkey SDK or the regular netbeans IDE?

I’m using the IDE bundled with the SDK.

We can add this flag to the next release.

Meanwhile you can fix it locally following the similar procedure (but using the flag from your logs):

Link to SDK issue: Add module exception to allow viewing Javadoc in the SDK · Issue #608 · jMonkeyEngine/sdk · GitHub


I’m ok with adding the flag, just can’t find out which file to add it into. I’ve searched for catalina startup or configuration files and can’t locate them. Where should the flag be added?

Find your SDK installation folder. It is folder etc just under there. In that folder there is a file called jmonkeyengine.conf. Edit it with i.e. Notepad. The file has a section called default_options. You’ll see similar flags added there.

To recap, the file is in:
<SDK installation folder>/etc/jmonkeyengine.conf

Thanks, it ended up requiring me to add two new options,


and now it works.


Thanks for confirming this!