Imposible to merge simple geometries

I’m just trying to merge geometries on one single mesh for generating dynamic navigation meshes. The method I use is:

GeometryBatchFactory.mergeGeometries(geomtries, optiMesh);

The problem comes when I try to merge simple geometries (just wirebox/box and quads created from the scene models’s bounds to make the navigation mesh generation more efficient). The merge method just stucks. The material the geometries have is:

new Material(assetManager, "Common/MatDefs/Misc/Unshaded.j3md");

The geometries are created for this purpose so all of them use the same material instance.

(¿Is there already implemented any other method that does the same but with raw meshes?)

So… it continues on forever and ever and never completes? How long did you let it run? Did you try running it in the debugger?

It can merge simple geometries just make sure you aren’t also trying to merge it with more complex geometries that have tangent buffers or a whole lot of other types of attribute buffers. All meshes must have the same kinds of buffers.

I let it run for quite minutes. If, instead of that geometries, I use the original ones it ends on seconds or less. I added all the geometries on the list to the scene to be sure what I’m trying to merge and all is fine:

(I changed the wirebox materials to see them, white on white is quite difficult ;))

They are just WireBoxes (the boxes) and a Quad (the floor).

Edit: Ok, I just looked at their buffers and the WireBoxes differs on the quad on:

[VertexBuffer[fmt=Float, type=Position, usage=Dynamic, elements=12], VertexBuffer[fmt=Float, type=TexCoord, usage=Dynamic, elements=8], VertexBuffer[fmt=Float, type=Normal, usage=Dynamic, elements=12], VertexBuffer[fmt=UnsignedShort, type=Index, usage=Dynamic, elements=6]]
[VertexBuffer[fmt=Float, type=Position, usage=Dynamic, elements=24], VertexBuffer[fmt=UnsignedShort, type=Index, usage=Dynamic, elements=24]]

Edit: I just tried to change the wireboxes by boxes and, suddently, today it works -.- (I’m sure I tried it yesterday, maybe it was too late and my mind started to ramble :S). Oviously, if I had mentioned that it runned on another thread it would be easier to find the problem as it throws:

java.lang.UnsupportedOperationException: Cannot combine different primitive types: Triangles != Lines

Thanks for your help!!!