Installing with netbeans

i followed the tutorial to install jME2 into netbeans (, and after following all of the instructions (which i think have some errors, i followed them as closely as possible).

when i tried to do any of the tutorials, none of the imports for anything in com.jme worked. with my project, i added the 4 libraries, two compile, two run into the appropriate areas, and the correct run code.

i also tried to install jME2 into eclipse, but the video tutorial gave bad links, and seemed to be done on a different version of eclipse, and with the written tutorial i couldn't find "SVN Team Provider" and the link provided incase it wasn't there, isn't an svn repository.

i really want to use jME2 with netbeans, but i couldn't get it to work with anything. any help is greatly appreciated. thanks in advance.

I’m presently writing down some tips for jme 2 and netbeans 6.7 (should also work with 6.5).

Please try that and tell me whether it works for you, or where it needs improvement.

your tutorial was helpful, although rather confusing at sometimes, i was able to figure out everything you meant.

after copying all of the code from the file (although you might want to note that you have to change the package name), unlike my earlier attempts with the other tutorials, the imports worked, and there were no errors. however when trying to run the file, i received this:


java.lang.NoClassDefFoundError: Files/NetBeans

Caused by: java.lang.ClassNotFoundException: Files.NetBeans


        at Method)


        at java.lang.ClassLoader.loadClass(

        at sun.misc.Launcher$AppClassLoader.loadClass(

        at java.lang.ClassLoader.loadClass(

        at java.lang.ClassLoader.loadClassInternal(

Exception in thread "main" Java Result: 1

BUILD SUCCESSFUL (total time: 1 second)

Pojo226 said:
(although you might want to note that you have to change the package name)

Thanks, I added that now!

Pojo226 said:

java.lang.NoClassDefFoundError: Files/NetBeans
Caused by: java.lang.ClassNotFoundException: Files.NetBeans

Hm, I never got that. Search for this text (Files.NetBeans or Files/NetBeans) and see in which context it appears? Is the NetBeans error output a blue hypertext link to the affected line?

i had deleted the package after i copied the output, but to recopy it i remade the package and added the same code, however now there are import errors.

I updated a big part of the tutorial over the weekend.

I also added a section about packaging.

When you get import errors, do you see those yellow/red lightbulb things at the left edge of the editor? Often clicking them can fix the imports and other errors and warnings.

alright, i followed your tutorial again from scratch. this time i had no import errors, or any errors at all, but when i tried to run the program i received this:


Jul 13, 2009 5:32:02 PM start

INFO: Application started.

Jul 13, 2009 5:32:02 PM com.jme.system.PropertiesGameSettings <init>

INFO: PropertiesGameSettings created

Jul 13, 2009 5:32:02 PM com.jme.system.PropertiesGameSettings load

WARNING: Could not load properties. Creating a new one.

Jul 13, 2009 5:32:02 PM class hello3d.test.HelloWorld start()

SEVERE: Exception in game loop

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

        at java.lang.ClassLoader.loadLibrary(

        at java.lang.Runtime.loadLibrary0(

        at java.lang.System.loadLibrary(

        at org.lwjgl.Sys$

        at Method)

        at org.lwjgl.Sys.doLoadLibrary(

        at org.lwjgl.Sys.loadLibrary(

        at org.lwjgl.Sys.<clinit>(

        at org.lwjgl.opengl.Display.<clinit>(

        at com.jme.system.lwjgl.LWJGLPropertiesDialog$



        at hello3d.test.HelloWorld.main(

Jul 13, 2009 5:32:03 PM cleanup

INFO: Cleaning up resources.

Jul 13, 2009 5:32:03 PM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

Jul 13, 2009 5:32:03 PM start

INFO: Application ending.

BUILD SUCCESSFUL (total time: 2 seconds)

Hi Pojo, sorry for the late reply (my mail client trashes jme forum messages as spam) :x

This “java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path” is the error that everybody gets at least once, I guess, don’t let it discourage you. Did you figure it out in the meantime ?

If not, I extended my FAQ with tips.

i tried to follow the tutorial once or twice after the errors, but then i gave up and got busy with some other things. right now i'm getting interested in getting it to work again tho.

if your ever in IRC i'm generally in the jme channel under Pojo