Intellij Integration

I’ve added some checks and dialogs for read and write where applicable. I also noticed a potential issue related to the path of the model. I’ll push an update in the next few days. I’m also in the middle of adding context menus to the scene explorer to add lights and such, so I’ll have to finish that first.

It does also take 2 days for intellij to validate it, so I’ll try to be quick.

Thank you for the report.

I’ve pushed v1.0.2 to intellij. You should recieve an automatic update once it has been validated. I’m confident it should fix your issue, @Mr_Marbles .

1 Like

… OK . Sounds good… but why I cant see the plugin in the Settings ? :see_no_evil:

Click “File -> Settings -> Plugins”.

Make sure you have selected “Marketplace” and not “Installed” at the top. Search “jmonkey” and it should be there.

Of course. But there is no plugin available. Do I need a latest version of InteliJ or doesn’t matter ?

Yeah. I think 2019.2 is the minimum version.

You can also manually download it here, I guess.

1 Like

Will keep an eye out for 1.0.2 and report back. As of now it is still not available.

I think it’s available now (Help -> Check for Updates).

I have noticed that opening models from different modules causes this error. I’m looking into this issue now.

Confirmed, v1.0.2 is available now. Unfortunately it does not fix the issue with loading the boat from jme-testdata:

intelliJ-jme-plugin

However, I am now able to load models in other projects that previously did not work.

I’m seeing strange clipping of the 3D canvas into other regions of the IDE:

Annotation%202019-09-09%20100852

Oh. I see. If you do anything with the window it will resize properly. I guess I must have missed an event to resize somewhere.

I’ve tried both moving the camera in the scene, and resizing the IDE manually , but the issue persists.

What operating system and graphics card do you have? I’ll fire up some VMs and see if I can reproduce the issue.

I tried using the plugin to open a scene and just received an error dialog saying I don’t have permission to view that directory.

Edit: I just updated to v1.0.2

Ok thanks for the feedback. Something isn’t right. I’ll try to track it down.

OS: Windows 10 enterprise build 1809
Graphics Cards: Intel HD 630 & NVIDIA Quatro M2200

I’ve tracked it down. I noticed you had the SDK open and tried to open the boat model from the test-data sub-module, and in doing the same I am able to reproduce the error.

What “SDK” are you referring to? The jMonkeyEngine SDK? If so, I did not have that opened while using IntelliJ. I rarely use the SDK at all.

My mistake. I meant to say you had the “engine” open, not the “SDK”.

I’ve found the problem. I registered src\main\resources with the assetManager whenever a project opened, but in some projects this directory doesn’t exist (such as the engine), so when the assetManager iterated over the locators it would stumble upon that directory in the list and found that it doesn’t exist (is not a directory). In addition .canRead() would also return false (because it doesn’t even exist) and would trigger the permission error.

This problem has been solved so far as I can tell. I’ve opened .j3o and .j3m files from all manner of setups and haven’t encountered the issue again.

Since it takes so long for intellij to validate the plugin I’m going to add a few more things to the scene explorer before I push an update:

  • Add Nodes
  • Drag support for models and materials
  • Delete support for various objects
1 Like