Is anyone familiar with Ant? I need help!

Hi guys.
I want to ask, is anyone familiar with Ant build scripts?
I have encountered some problems that I cannot solve.
I hope to use SDK to complete the release of desktop games and Android games.
However, SDK3.3.2 (Jme3.3.2API) seems to have to run on jdk11?
When I build android, ant prompts that 1.5 source is not supported. as follows:

(Translation of the above error: source 1.5 is not supported, please select 1.6 or higher)

Change to 1.7 and package the APK, and then install an error:

The error seems to be that the jme3.3.2 API can only be executed on jdk11?

So I changed it to 11.
But I encountered a new problem, as follows:

(The translated meaning is: 11 does not support the --boot-class-path option)

The reason I don’t use AndroidStudio is that I don’t want to use SDK to maintain the desktop version, and then use AndroidStudio to maintain a separate Android version. I hope everything is done in the SDK.
Hope someone can help me, thanks.!

1 Like

I have no idea about these. But does this help at all: java - Javadoc error: "option --boot-class-path not allowed with target 11" - Stack Overflow

1 Like

What’s on line 716 & 730 build.xml ?:thinking:

1 Like

Hi, tonihele, thank you.
In fact, I studied all night last night and found several articles, and they came up with some solutions.
But since I am not familiar with ant, I don’t know how to modify the ant build script…

Hi, Pavl_G, I tried to delete this line, but I still get an error.

1 Like

I’m running 3.3.2 on JDK 8… and only within the past year upgraded from JDK7.

More likely an “android-not-real-Java” compatibility problem, I guess.


Thank you pspeed, I will continue to investigate what caused the problem.

About the NoSuchMehodError exception when using IntBuffer.clear, I had a similar issue recently. I found this stackoverflow page: Exception in thread "main" java.lang.NoSuchMethodError: java.nio.ByteBuffer.flip()Ljava/nio/ByteBuffer - Stack Overflow

To sum it up, this happens when mixing prior versions of java and java 11 because of some implementation changes in nio. I fixed it by adding --release N (8 in my case) to my gradle files. I’m sorry I can’t help you to do it with ant


Thank you, @joliver82 :wink:.
I will check this post.
@pspeed Do you have any thoughts on this? (Sorry, I know you are busy… :slightly_smiling_face:)

No additional thoughts.

You just said JME didn’t work with Java older than 11… and I’ve never run a Java newer than 8 and I use JME all the time. So that’s all I can say. JME works fine with Java 7 last I checked 6 months ago… and definitely with 8 because I’ve run it in Java 8 about 200 times today.

1 Like

It seems that I can only try the analysis mentioned in the above article to see if there is a solution. Thank you again for taking the time to reply.

A little off topic, but I actually use Android Studio to develop both my desktop and android apps. I just have a gradle project that contains what I need, and a subproject containing the android harness and other files. Since Android Studio is pretty much Intellij IDEA with a few extra features, it works pretty well. My JME Controller Config project demonstrates my setup pretty well, if you’re interested.

1 Like

Thank you for the solution :wink:. I will check it out. But I still need to use the functions of the SDK, such as adding Control to the editor, adding AudioNode, and using the editor to make levels.
I really don’t want to use the SDK to maintain the level, Control, and AudioNode information separately, and then use AndroidStudio to write the game logic and package the APK.
So I am still looking for the details of ant build. :face_with_thermometer:

maybe you already fixed it but I think that modifying javac tag to include source, target and/or release should work:


Reference on ant javac task: Javac Task


Oh, thank you, I haven’t fixed this problem yet, I will try your proposal. :wink:

1 Like