Issue when loading bone rigged mesh in jme(android) using

Hi Everyone,
I am using Jme:3.5 and building via android studio bumblebee, target SDK 32 min 21, development host ubuntu. I used gradle based project as is given in example as per discussion here. Now my project runs fine when I try to load meshes without bone rigging. I am using gltf exporter from blender. In SDK on desktop version the ,j3o(rigged skeleton mesh) file loads fine but trying to load in android code .j3o file goes haywire and outputs random wacky mesh.
On side note I tested on AVD and real device both and its same issue. Normal inanimated meshes are fine but with bone rigged meshes its an issue in android.

Hi @Anuj_Topiwala, Welcome to the community!

Is there any error or warnings logged?

Also, can you show us a screenshot of the model on Android?

Hey Thanks for quick reply. No there is no warning related to loaded model. However I ran again on my AVD with API 21 it works fine on there but in AVD API 24 level it showing whacky output.

So here is the test model on AVD - API 24 giving whacky output

(Sorry I cannot add both image in same post being new user so sending separately)

Here is the output of test model with AVD -API 21 and also in SDK desktop.

Okay I tried running on AVD- API 32,21,26 also my compile API level is 32 and its loading properly so issue is with API 24. Will test on other devices too and actual device.
The issue seems to be present in api 24,25 (Android noughat) as I tested on Android 9 device not avd and it loads properly. Is this due to vertex buffer read getting whacky as discussed in this thread JME3.1 - Rendering failure specifically for android 7 (Nougat) - #23 by pspeed?

okay so going through the discussion Here I was able to see my test model even in api 24,25 AVD and in actual device by disabling hardwareskinningcontrol aka GPU skinning. So is there any fix for this ? This problem is peculiar to android noughat versions