J3o editor prototype

Hello. I want to write a level editor, so I started by creating a j3o editor as a prototype. Before I start with the main editor, I want to collect some feedback.
It’s best not to save any models you still need using the editor, since it is not guaranteed to be stable. I think the best is to load and save only copies of the used j3o files.

When starting with the program arg


, it will not create a config file.


Hi @Nakano.

I wanted to try your project, but I can’t compile it due to lack of dependencies.

import online.money_daisuki.api.base.ArgumentHandler;
import online.money_daisuki.api.base.ArgumentParserResult;

In file build.gradle it doesn’t look like you are implementing such a library.

The construction of this project is somewhat strange.

  • Do you normally create your projects this way?
  • How can I run it?

Thank you. I’m an idiot, forgot to add my own api projects. Fixed it.
The structure comes from the fact that I use Eclipse to develop.

1 Like

You are using AWT-Swing components with lwjgl3.

lwjgl3 does not support class LwjglCanvas (at the moment), so it throws this error:

java.lang.ClassNotFoundException: com.jme3.system.lwjgl.LwjglCanvas
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:641)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:188)

You can use lwjgl (so I can’t test it, shame :smiling_face_with_tear:) but it has problems with X11 which Linux distributions use.


Thank you very much. I changed the context type to Display as hotfix.
When starting with the program arg


it will not create a config file.

I tried to fix all which seems to be incompatible with LWJGL3 and the X-Server, for example the JFileChooser, but it crashes still randomly (LWQt):

X Error of failed request: RenderBadPicture (invalid Picture parameter)
Major opcode of failed request: 140 (RENDER)
Minor opcode of failed request: 7 (RenderFreePicture)
Picture id in failed request: 0x3c00102
Serial number of failed request: 9747
Current serial number in output stream: 9748

It seems the jME SDK uses the AwtPanelsContext by default. Is that the right way to do?

The SDK is using LWJGL 2. That is why it works. Swing/AWT and LWJGL 3 is a bad combination.