Java Mime Type Not Found

I recently tried to update the SDK on my OSX laptop and ran into a SDK bug where it won’t register the Java MIME type and as a result I can’t open java files in the sdk. From what I can tell this is a bug with the version of netbeans the current sdk uses and not the sdk itself.

A Link to one of the variations of this bug

I mainly wanted to put this out there and see if anyone else was running into it. Is it possible to update the netbeans version of the sdk on my own easily or has anyone else figured out a workaround?

:-? I use the latest OSX and SDK and I can open java files in the SDK. What do you mean exactly btw, opening files from the finder or from within the SDK?

Like I try to open any java file from within the sdk and it will show a blank screen with no information. I looked into the sdk log and it showed an error trying to load the java mime type. From what I understand it is a timing issue so you wouldn’t necessarily run into it.

This is the actual exception but I can link the entire IDE log if you want.

SEVERE [org.openide.util.Exceptions]
java.lang.IllegalArgumentException: No parser for mime type: text/x-java
at org.netbeans.modules.parsing.api.ParserManager.findParser(
at org.netbeans.modules.parsing.api.ParserManager.parse(
[catch] at
at java.util.concurrent.Executors$
at org.openide.util.RequestProcessor$
at org.openide.util.RequestProcessor$

I also noticed that there are a bunch of warnings for the jmonkey sdk mime types that all look like the following:

WARNING [org.netbeans.modules.openide.filesystems.declmime.MIMEResolverImpl]: Ineffective registration of resolver Services/MIMEResolver/JMEMaterialResolver.xml use @MIMEResolver.Registration! See bug #191777.

I have the same issue with JME3 updated just today, atop OS X 10.9.3

Within the JME IDE, I get the same exception and stack trace as Greg Hoffman

My “About jmonkeyplatform” offers this info:

Product Version: jMonkeyEngine SDK 3.0
Java: 1.7.0_51; Java HotSpot™ 64-Bit Server VM 24.51-b03
Runtime: Java™ SE Runtime Environment 1.7.0_51-b13
System: Mac OS X version 10.9.3 running on x86_64; US-ASCII; en_US (jmonkeyplatform)
User directory: /Users/tone/Library/Application Support/jmonkeyplatform/3.0
Cache directory: /Users/tone/Library/Application Support/jmonkeyplatform/3.0/var/cache

Did any of you get a screen about disabled plugins when you started the SDK? How does the list of installed plugins look?

I didn’t get a screen about disabled plugins. I remember checking to make sure all the normal plugins were installed but I could check again later tonight when I get home to be sure.

I don’t recall that I did. I deleted my ~/Library stuff for JME3, deleted the app and re-installed. This issue is not occurring if I run the app and do not update the 35 things it tells me are stale.