JME 3.2.1 Mac Installer on OSX 10.13.3 not Launching [SOLVED]

I am trying to install JME 3.2.1 on my MBP with 10.13 High Sierra. Not sure if it matters, but I have JDK and JRE 9.0.4 installed. The installer will briefly open and then close without any errors or indications as to why it wont install. Are there any known issues that prevent the installer from launching in Mac? I can’t seem to find any solutions from Google. Thanks for the help in advance.


Netbeans (and by extension the JME SDK) can not be run on Java 9. At least last time I checked a few weeks ago.

Yeah but the SDK should provide a JDK on it’s own, however due to some bug that doesn’t work as expected.
There was a post on here about that topic, I don’t have the link at hand but you should find it easily.
The other workaround would be using the last 3.1 release (which is very inconvenient, sorry)

1 Like

Thanks jmaasing and darkchaos. I removed Java 9 and installed 8. Seems to work fine.

1 Like

So in theory this should be resolved in Release v3.2.1-stable-sdk2 · jMonkeyEngine/sdk · GitHub

If you want you may try this again with java 9 (what it does is it comes with it’s own jdk8).
I tried it on my mac but since I’ve had java 8, I did not have the issue. I can’t tell you if it’s fixed because the installer still prints “Looking for System JRE”, so the bundled one seems to be only a fallback in that case.

Anyway, if someone is seeing this thread and having issues, feel free to notify me.

Just fyi this is still an issue. I wasn’t able to run any of the current sdk builds unless I based the jdk location in by hand using --javahome. It could possibly be an issue because I use jenv to switch between java versions. I don’t know what that does to the install script but it doesn’t fall back to the included jdk.