Jme and jogl?

Is this still under consideration?

Thx Chman! This is great! :slight_smile:

I’ve been using Jogl with the Java3d scene graph and would really like to try jME as well. I don’t know if it’s versioning or what, but I’m having a lot of compatibility issues between Java, jME and lwjgl. Very frustrating…

While waiting for JOGL, you may try the LWJGL demos themselves, to see if you are having a LWJGL problem or a jME problem.

What sort of compatibility issues do you see?

As always, make sure your drivers are updated.

Does the same thing happen when you run off the webstart demos on the site?

@renanse; currently, the two computers I use for Java development don’t have direct access to the Internet as I’m moving my home office and network around. I’ll be re-connecting them next week via cable modem so I’ll be able to test using web start. I’ll post those results as soon as I can. :wink:

Just as a side note, I can run all the Java3D v1.3.1 and Jogl v1.1b07 (NeHe conversions and bundled) examples without any problems on both machines. Very curious…

I had a very similar problem to this, the conclusion is that I came to is that its a bug in the JVM.

  1. make sure that if you have a JRE installed that it is the same version as the JDK. If not, standardise on one version.
  2. there is definitely an issue with jME and 1.4.2_6 on some PCs, use either 1.4.2_4 or 1.5 instead - note if you use 1.5 you will get type conversion warnings; just ignore them :slight_smile:
  3. note that some editors have their own JRE built into them which can cause the same conflict as point 1. If you still have a problem after steps 1 and 2 try un-installing your editor temporarily and running the tests from the command line.

    Let us know how you get on.

@mgscox; I’m thinking the same thing, a bug in the VM. The fact that the jME/lwjgl examples run for about 5 seconds then dump with a thread error seems to point that way. But just to be sure:

Item 1, We’re good. Same jre and jdk versions.

Item 2, I’m going to upgrade one of my boxes to 1.5 this afternoon and see what happens. Thx for the heads up on the type conversion warnings.

Item 3, jGRASP is configured to use the installed jsdk/jre on my computer so I think I’m ok there.

I’ll post more info later. Thx. :wink:

Ok, I’ve removed 1.4.2_03 completely and installed 1.5.0_01 on one of my XP SP2 boxes. I then successfully compiled jME CVS and installed the appropriate .jars and .dll files. Here’s the output from trying to run the HelloWorld file:

----jGRASP exec: java jmetest.TutorialGuide.HelloWorld

Jan 8, 2005 10:09:50 AM start

INFO: Application started.

Jan 8, 2005 10:09:50 AM com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

Jan 8, 2005 10:09:50 AM com.jme.system.PropertiesIO load

INFO: Read properties

Jan 8, 2005 10:09:54 AM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

Jan 8, 2005 10:09:55 AM com.jme.system.PropertiesIO save

INFO: Saved properties

Jan 8, 2005 10:09:55 AM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.


An unexpected error has been detected by HotSpot Virtual Machine:


EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d6c5b0b, pid=1032, tid=1976


Java VM: Java HotSpot™ Client VM (1.5.0_01-b08 mixed mode, sharing)

Problematic frame:

V [jvm.dll+0x85b0b]


An error report file with more information is saved as hs_err_pid1032.log


If you would like to submit a bug report, please visit:


----jGRASP wedge2: exit code for process is 1.

----jGRASP: operation complete.

The app tries to run, blanks the screen for a second then dumps… I’ve tried several of the other jME examples and they all produce the same results.

Again, I’ve tested with both the lwjgl files that are bundled with the jME CVS and with lwjgl 0.94-2 from the lwjgl site. The java3D and Jogl examples work perfectly… The NeHE lwjgl examples now work correctly as well.

Argghhh! :?

The crash log is pointing at the JVM I notice

# Problematic frame:
# V [jvm.dll+0x85b0b]

Did you download the JAR files or did you build them on your machine using ANT ?

If you downloaded them then I'd recommend checking them out of CVS and building them under ANT. It's very easy to do and is all explained here:

Can you tell I'm starting to grab at straws here? ://
Can you tell I'm starting to grab at straws here?

heh, no problem! I appreciate the suggestions and help. I'm grabbing at straws myself! ;)

I've built the jme.jar files from CVS source using ANT and followed the same build procedure each time I've tested. I'm trying to get a handle on the jME internals to see if I can determine the problem but my programming background is in C and C++ so it's taking some time.

I'm thinking it's in the VM as well... Anyone else having this problem?
# Java VM: Java HotSpot(TM) Client VM (1.4.2_06-b03 mixed mode)

jme has problems with some VM (including this one) see

I don’t know jGRASP - I guess it’s possible that there’s something to do with the project file and libraries going wrong. Have you tried to run the apps from the command line? Also, have you tried to run the WebStart demos?

@badmi; thx, I read through that thread after I posted my first problem (and, after I’d already updated my Java install :frowning: ). BTW, I hope your jME/jogl project is coming along. I’m really looking forword to it. :slight_smile:

@mgscox; I get the same error from the command line. :frowning:

If you’re looking for a good program to build java apps in that’s more lightweight and easier to use than Eclipse or NetBeans, I suggest jGRASP. It’s got a lot of great features. I use it all the time for my java work.

I can’t run the jME examples from web start because my two development work computers are not connected to the ‘net right now. I’m moving my consulting/programming business to my home. I have to download stuff through my wife’s computer by modem, and then transfer to mine via zipdisk. Next week I’ll have my cable access and wireless network set up… 8)

Anyway, I’ll keep plugging along and see if I can remedy the problem tho’ I’m still inclined to think it’s with the VM at this point. I wonder if Sun made changes to 1.4.2_05 and 06 that were incorporated in 1.5 as well? More straw grasping…

What graphics card are you using? It almost seems that with the internal error something is happening in JNI to cause it to crash. Perhaps some deep OpenGL system crash?

I finished the jogl renderer. You can fined information and files on in Dev General. Mojo dose not want to put it inside the cvs until .9 is out so if you want to use it you will need to patch the files yourselves.