JME on Mac 10.6.8

Greetings, I am really interested in working with the Jmonkey engine.

My current computer is running OS X 10.6.8

I tried using terminal to unzip the jME3_SDK_Beta-macosx.tgz file, could not do this.

also tried using terminal to run the jME3_SDK_Beta-macosx.tgz file as a program,

and this did not work either.

Sorry if I seem a bit dim at this stage…

could anyone direct me as to how to get the JME up and running on the mac please?

I also tried directly double-clicking the jME3_SDK_Beta-macosx.tgz file, and the Archive Utility progress bar runs,

then a message shows: "Unable to unarchive jME3_SDK_Beta-macosx.tgz into “[the folder it is in]”.

(Error 1 - Operatioin not permitted.)

Perhaps would be better to use the Jmonkey JME with Netbeans or Eclipse on Mac?

I found a tutorial on how to use JME 2.0 with Netbeans…

Is this an advisable way to go?

Sorry about all the questions, hope that is okay for a first post.

Thanks for any help and best regards,


quick post to mention the details of what i typed on Terminal:


cd /Library/jmonkey

sudo chmod 777 jME3_SDK_Beta-macosx.tgz

** all okay up to this stage, and then…

sudo unzip jME3_SDK_Beta-macosx.tgz

** this is the response:

Archive: jME3_SDK_Beta-macosx.tgz

End-of-central-directory signature not found. Either this file is not

a zipfile, or it constitutes one disk of a multi-part archive. In the

latter case the central directory and zipfile comment will be found on

the last disk(s) of this archive.

note: jME3_SDK_Beta-macosx.tgz may be a plain executable, not an archive

unzip: cannot find zipfile directory in one of jME3_SDK_Beta-macosx.tgz or, and cannot find jME3_SDK_Beta-macosx.tgz.ZIP, period.


in terminal, i typed the following:

tar -xzf jME3_SDK_Beta-macosx.tgz

to kind of force the unarchiving process to happen, which it did, and the following program appeared alongside the .tgz file:

jMonkeyEngine SDK Installer

So, that was great…

But when I double click that, there is a message saying:

“You can’t open the application jMonkeyEngine SDK Installer because it may be damaged or incomplete.”

I have downloaded the .tgz file (jME3_SDK_Beta-macosx.tgz) twice from here:

Thanks for any help…


I tried using Stuffit Expander (version 15.0.4, that is the most recent free version)

During the unarchive process, a message said:

“A problem has occurred while expanding the archive.

The item ‘bundle.jar’ was created by a newer version of Stuffit and cannot be expanded by this version.”

Re-download. This doesn’t happen normally, your file must be corrupted.

yes, I will re-download. Cheers for the reply.

completed the download and everything works perfectly, thanks so much…

installed the engine…

achieved tutorial 1, and now onto the next, “Hello Node”.

JME3 is phenomenal and awesome.

1 Like