jME on Windows 7 x64 just can't launch

Hello everyone, I recently bought a new computer with Windows 7 64 bits version, and I wanted to install jMonkeyEngine on it. So I downloaded and installed the jME3 SDK with the lastest jdk for java6 and everything worked right.

But when I want to launch the software nothing happens, the hourglass is displayed and disappears few seconds after. No warning message, no error message.

Can someone help me please, this kind of installation worked fine on another windows 7 OS, so I wonder if I have forgotten some requirements on my new computer to make jME work…


-OS Windows7 x64

-Intel core i5-2410M, 2.3 GHz

-Ram 4Gb

-Graphic Card AMD RadeonHD 6700M Series

Thank you for your help :slight_smile:

One thing is for sure, this isn’t Win7’s fault. I’ve been running jME/jMP on Win7 x64 since forever and never had that.

Your post is a bit confusing though. You’re talking about jME. jME is the engine. jMP is the IDE. Do you have a crash running jMP or running an “app” you made with jME?

Oh sorry about that, actually I’m talking about jMonkeyPlatform, I tried the jME with eclipse and it’s working.

There isn’t crash with jMP, it just refuses to launch, without any error message.

Works fine on my Windows7 64bit Intel with Intel(!) graphics, definitely no general windows issue. Make sure you first install the JDK and then the jMonkeyEngine SDK, run from the command line to see any errors.

I’ve juste uninstalled and reinstalled all java components in the following order: java 32 bits ; jdk1.6.0_29 for 32 bits ; jME SDK

(I think it should be working also for 32bits version of java on a 64bits OS, am I right?)

Same problem, when I launch either the shortcut on desktop named “jMonkeyEngine SDK” or its reference file in ProgramFiles named “jmonkeyplatform.exe” nothing happens.

I tried to launch it using the terminal, this is its answer:

I think when you use a 32bit software it has to be installed in Program Files(x86) or something… Also make sure its actually run with the 32bit jvm (Java Settings). Why you try running in 64bit? Whats the actual error output on 64bit?

Yes, java 32bit was installed in Program Files(x86)…I didn’t found where was the Java Setting for the jvm…

I tried again with java 64bit (java 64bit + sdk 64bits reinstalled) and the error message is exactly the same in the console.

Just saw that link-as-an-image thing you inserted now… Looks like some user rights issue… Running as admin might get rid of that but somethings messed up on your system.

From the error message you get there seem to be something wrong with the “lock” directory.

The message says that access is denied.

Okay, I’ve changed the running mode

This is the current error output:

Thats not a Program Files x86 folder…

Actually as the error messages were the same with 32bit and 64bit I’ve reinstalled jMP in the default install directory (eg ProgramFiles) with java 64bit and the jdk 64bit ( there is no more things in Program File (x86) except java 32bit and the jdk 32bit)

You’re trying to setup your user directory into the “Program Files” directory. You can’t do that.

…xD…is my command line wrong? I thought that it would only execute jmonkeyplatform.exe (I’m not very experimented with the windows console)

Sorry about that T.T

Would you have any solution to identify the problem, it has been 2 weeks since I try to solve it…?

In my experience after installing jMP you run it. It’ll ask you where to put the user’s directory. You choose a proper directory, could be in your “My Documents” or wherever you want as long as it’s not in the “Program Files …” directory.

Installing and running jMP is usually pain free. You should’ve posted before today. 2 weeks? Me thinks you’re masochist a bit. :wink:

Actually I tried several uninstalls/reinstalls and many google researches to find a solution, I have a other (less powerfull) computer with windows 7 and jMP works on it !! So I thought the problem shouldn’t be too serious…until today xD!!

Anyway, the main problem remains that jMP refuses to launch, even the first time after installing…that is why I thought that, as my computer is relatively new, I do have missed the install of some required components…but that doesn’t seem to be the problem…

(Thank you both for your help :slight_smile: )

The only lock files I have that are somehow associated with jMP are in:




I honestly don’t know where that testuserdir comes from though. O_o

Stupid forum is escaping my backslashes… Well, you probably can guess where those are.

yeah…It start to be a little bit complicated for me… I think I’ll give up, and use Eclipse with the nightly build to make my games.

Anyway, thank you for your help :slight_smile:

Hum…I just reinstalled jMP and rebooted my computer, and it’s working(!!!)…I don’t know why and what messed up before, I changed nothing xD!