jme3 can not see the code editor

Hi all,

i have downloaded and installed the jme3-mac-sdk from

But when i open the jme3-ide and try to start open/write a class like described in
i get “diff-window” which shows my the history in compare mode: diff to current.

Is this a known bug because i could not find anything about such a behavior.

what i tried was to open the new created helloworld project in netbeans by adding all jars from the content of the skd and it worked but i would prefer to use the jme3-ide3.

have some one a idea how i can get the source code editor in jme3-skd?

Thanks in advance.
regards cupido

additional info: my OS is Mac 10.9.4

additional info:

right click on the “diff-window”/ tab i get a popup window with the last entry “Editors”

in jme3-ide i can just select “History”
in netbeans i have the option between “History” and “Source”(which i want to see)

You can try using the installer (tgz) from instead of the zip file, depending on your OSX version you’ll have to open the installer package (right-click->view package contents) and run the contained jar file manually as there is a bug with the installer on later OSX versions.

still the same behavior. no source code editor available. I tried it that way without succuss:


extrated and gone into:
jMonkeyEngine SDK SDK Installer

executed in terminal:
java -jar bundle.jar
let the graphical installer run without creating icons

is it possible that the “source-editor.jar” is missing in the bundle?

regards cupido

i’ve got it. i had some years ago a beta version of jme3 installed. after deleting in

/Users/“userNAME”/Library/Application Support/jmonkeyplatform

the folders 3.0 and 3.0beta and installing the sdk (zip or tgz) it works as should.

thanks and regards

1 Like

Thanks for reporting back, this is very helpful information.