jME3 Platform very unstable on Ubuntu?

Ive updated to the most recent build, but I am still experiencing crashes whenever I do anything with OpenGL Window (Scene Viewer). (right click and try to close, try to pop out of the tab into new window, window->reset, etc…) jMP becomes unresponsive and I have to go into system monitor to kill the process. The CPU does NOT jump to 100% when it freezes.

When I first installed the platform, the scene viewer showed a globe and it worked (although I had no idea what it was supposed to do at that time). Now when I fire up jMonkeyPlatform Alpha-4 I immediately get :

Error in scene! (java.lang.illegalStateException: Display not created)



Error in scene!

Error in scene! (java.lang.illegalStateException: Keyboard must be created before you can poll the device) [note : this is new since the update, and the keyboard works fine]



Error in scene! (org.lwjgl.LWJGLException: X Error - disp: 0x95cca80 serial: 44 error: BadValue (integer parameter out of range for operation) request_code: 1 minor_code:0)


A small test app I wrote (renders a textured, rotating cube) runs fine.

System info : (shes a little old but solid otherwise)

OS : Ubuntu (Karmic)

ram : 1.5GB

Video Card : Nvidia GeForce FX 5200

java version “1.6.0_20”

OpenJDK Runtime Environment (IcedTea6 1.9.8) (6b20-1.9.8-0ubuntu1~10.04.1)

OpenJDK Client VM (build 19.0-b09, mixed mode, sharing)

Plenty of HD space (>90GB free)

Here are some error messages from before the update :

org.lwjgl.LWJGLException: X Error - disp: 0x8314648 serial: 26 error: BadValue (integer parameter out of range for operation) request_code: 1 minor_code: 0

at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(

at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method)

at org.lwjgl.opengl.LinuxDisplay.createWindow(

at org.lwjgl.opengl.Display.createWindow(

at org.lwjgl.opengl.Display.create(

at org.lwjgl.opengl.Display.create(

[catch] at com.jme3.system.lwjgl.LwjglCanvas.createContext(

at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(




at org.lwjgl.opengl.GL11.glGetString(

[catch] at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(



java.lang.IllegalStateException: Cannot determine close requested state of uncreated window

at org.lwjgl.opengl.Display.isCloseRequested(


[catch] at

A bit frustrated, as this has been something I have been hitting as hard as I know how to for the better part of 2 days. Otherwise, I freaking love this platform.

Continued efforts (may as well treat this as a log lol)

on a whim, I ran
sudo ./jmonkeyplatform
I get the same errors, but I can at least click on the sceneviewer tab without it freezing up the whole platform, although this* just displays a blank (empty) content area.
*EDIT : I believe this is because I at one point chose [Disable Modules and Continue] at one point.
uninstalled jME platform, reinstalling....
Upon trying to run the shortcut, I get : Warning - could not install some modules..., with the option to [Disable Modules and Continue]. I chose to Exit at this point.
Ok, I can get it to work, and replicate the problem. It boils down to me being a linux noob.

To recreate the problem from a fresh install :

It creates a shortcut in Applications -> Other -> jMonkeyPlatform. If you add that to your quick launch bar (right click it -> Add this launcher to panel), and then look at the properties of that new link (right click the link on the quick launch bar -> Properties), then you can see the Command parameter this is being launched with. (/bin/sh "/usr/local/jmonkeyplatform2/bin/jmonkeyplatform" on my system). Clicking that (or running ./(that command) from terminal) cause it to break as I have described above.

To fix :

Open up terminal.
cd /usr/local/jmonkeyplatform2/bin [the path to where is]
sudo ./jmonkeyplatform
voila! It works! (at least the globe thing shows up, and you can click on the window w/o it crashing)

In summary :

Try running it with root privileges from terminal.

I bet there are things mentioned here that would make a real linux user cringe, (for example I think running stuff with root may be a nono), but hey, Im a noob lol.
1 Like

Yes, Linux has some problems lately which are high on the list before beta release. Thanks for the detailed feedback.

No prob, I love this framework. Im gonna build something awesome with it.