Jme3 Utilities Build Problems

Hello everyone.

I very much wanted to try out the SkyControl project and use it on my game. I followed the instructions at carefully and did get the jme3-utilities file in my projects folder. I also downloaded the jcommander-1.47.jar file and added it to the project library. After I did that, the system detected that the jar file had been added and gave me a little green check mark. Even so, I still cannot build the project successfully. Within the source packages under the jme3-utilities project, I am still missing files in the math, nifty, sky, and sky.test subfolders. I am not entirely sure what I did wrong, as there are no jars still reported missing. In addition, I thought about manually downloading the jme3-utilites jar and manually putting it into my project (because I somehow got the jme3-utilities-assets.jar) but all of the links that I found no longer worked. I am very lost >.<

Just install the skycontrol plugin via Tools->Plugins?

If the plugin is called SkyControl, then I don’t think it is in the plugin menu right now. Here’s a screenshot of what I get when I search for “sky”. All I find is “SkyDome”, which I’ve read is fine but has fewer features than the skyControl.

EDIT: It may have something to do with the fact that I cannot connect to the update center, which I realized when I tried to download skyDome as a test. I tried changing the proxy settings to “no proxy” as was suggested when I tried to “Check for updates” but it didn’t do any good. Any ideas?

Funny, it used to be in there, seems like theres an issue with the compilation. Anyway you can download a compiled version here:

So if I dump those jars into my project via properties->libraries->add jar/folder, it should work?