JME3-VR and Oculus Rift DK1


I own the 1st version of the Oculus Rift DK1. I was wondering if people had already used JME3-Vr with this version?

At the same time, if someone can help me explain the procedure of intialisation under Linux.

I think I have correctly installed version SDK 0.5.01 beta2 linux but I do not understand how I have to initialize everything with JME3-VR. (latest version for the DK1)

Currently, my boot class inherits from VRApplication.

I automatically have an exception :

This VR view manager is not attached to any VR environment.
at com.jme3.input.vr.openvr.OpenVRViewManager.initialize(
at com.jme3.system.lwjgl.LwjglWindowVR.initInThread(
at com.jme3.system.lwjgl.LwjglWindowVR.create(
at com.jme.example.Starter.main(

But concretely, what should I do next?

Thank you in advance for the explanations


I haven’t tried the DK1 with jme3-vr. OpenVR may not support the Oculus SDK 0.5.
What you can try is using the legacy plugin, found on my github:

It may have other compatibility issues now, but worked for DK1 back in the day. I used it with SDK 0.5

Thanks, i will try