jMonkeyPlatform:stability issues

I’ve downloaded and tried to work with the latest jMonkeyPlatform Alpha 3. The first problem is that I’ve noticed is that more than one time I would double-click on the icon, get the loading splash, and then sometime later the whole app would just “disappear”. I’m guessing that it crashed but I don’t know because it just wasn’t running when I came back it just wasn’t there. When it did run, I received an error message:

Exception in scene!

(com.jme3.rendererer.RenderException:Invalid ID received when trying to create a shader program.)

Look, it just happened again while I was writing this message: I tried to switch over to the app to read the message, had a delay while the processor was busy, and then the app wasn’t running. To say that this has happened more than once would be an understatement. I can close that dialog, and even got so far as to create a simple project, before it crashed again. It seems like the app won’t run more than a few minutes. Any ideas?

OS? GPU? CPU? Latest graphics drivers installed?

Windows XP SP3. Intel Core 2 Duo (4 years old). ATI Mobility Radeon X1400 graphics card, latest drivers, as far as I know.

From messages.log:

Log Session: Monday, December 6, 2010 6:52:49 AM EST

System Info:

Product Version = jMonkeyPlatform Alpha-3

Operating System = Windows XP version 5.1 running on x86

Java; VM; Vendor = 1.6.0_22; Java HotSpot™ Server VM 17.1-b03; Sun Microsystems Inc.

Runtime = Java™ SE Runtime Environment 1.6.0_22-b04

Java Home = C:Program FilesJavajdk1.6.0_22jre

System Locale; Encoding = en_US (jmonkeyplatform); Cp1252

INFO [com.jme3.system.lwjgl.LwjglDisplay]: EDT: Creating OGL thread.

INFO [com.jme3.system.lwjgl.LwjglDisplay]: Using LWJGL 2.5

WARNING [org.netbeans.core.TimableEventQueue]: too much time in AWT thread null

INFO [com.jme3.system.lwjgl.LwjglDisplay]: Display created.

INFO [com.jme3.system.lwjgl.LwjglDisplay]: Adapter: ati2dvag

INFO [com.jme3.system.lwjgl.LwjglDisplay]: Driver Version:

INFO [com.jme3.system.lwjgl.LwjglDisplay]: Vendor: ATI Technologies Inc.

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OpenGL Version: 2.0.5883 WinXP Release

INFO [com.jme3.system.lwjgl.LwjglDisplay]: Renderer: ATI Mobility Radeon X1400 x86/SSE2

INFO [com.jme3.system.lwjgl.LwjglDisplay]: GLSL Ver: 1.10

INFO [com.jme3.system.lwjgl.LwjglTimer]: Timer resolution: 1000 ticks per second

INFO [com.jme3.renderer.lwjgl.LwjglRenderer]: Caps: [FrameBuffer, FrameBufferMRT, OpenGL20, ARBprogram, GLSL100, GLSL110, TextureCompressionLATC]

INFO [com.jme3.asset.AssetManager]: DesktopAssetManager created.

INFO [com.jme3.renderer.Camera]: Camera created (W: 640, H: 480)

INFO [com.jme3.renderer.Camera]: Camera created (W: 640, H: 480)

INFO [com.jme3.input.lwjgl.LwjglMouseInput]: Mouse created.

INFO [com.jme3.input.lwjgl.LwjglKeyInput]: Keyboard created.

Diagnostic information

Input arguments:




























Compiler: HotSpot Tiered Compilers

Heap memory usage: initial 24.0MB maximum 494.9MB

Non heap memory usage: initial 258.2MB maximum 304.0MB

Garbage collector: Copy (Collections=21 Total time spent=0s)

Garbage collector: MarkSweepCompact (Collections=1 Total time spent=0s)

Classes: loaded=5320 total loaded=5320 unloaded 0

INFO [org.netbeans.core.ui.warmup.DiagnosticTask]: Total memory 1,072,029,696

INFO [null]: Total physical memory 1,072,029,696

INFO []: Audio effect extension version: 1.0

INFO []: Audio max auxilary sends: 2

INFO [com.jme3.renderer.Camera]: Camera created (W: 120, H: 120)

INFO [com.jme3.material.MaterialDef]: Loaded material definition: Default GUI

INFO [de.lessvoid.nifty.Nifty]: gotoScreen [start]

INFO [de.lessvoid.nifty.Nifty]: gotoScreenInternal [start]

INFO [de.lessvoid.nifty.effects.EffectProcessor]: starting effect [(Fade)]

com.jme3.renderer.RendererException: Invalid ID received when trying to create shader program.

at com.jme3.renderer.lwjgl.LwjglRenderer.updateShaderData(

at com.jme3.renderer.lwjgl.LwjglRenderer.setShader(

at com.jme3.material.Material.render(

at com.jme3.renderer.RenderManager.renderGeometry(

at com.jme3.renderer.queue.RenderQueue.renderGeometryList(

at com.jme3.renderer.queue.RenderQueue.renderQueue(

at com.jme3.renderer.RenderManager.renderViewPortQueues(

at com.jme3.renderer.RenderManager.flushQueue(

at com.jme3.renderer.RenderManager.renderViewPort(

at com.jme3.renderer.RenderManager.render(

at com.jme3.gde.core.scene.SceneApplication.update(

at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(

at com.jme3.system.lwjgl.LwjglCanvas.runLoop(



WARNING [org.openide.util.ImageUtilities]: Initial slashes in Utilities.loadImage deprecated (cf. #20072): /com/jme3/gde/core/sceneexplorer/nodes/icons/bitmaptext.gif

INFO [com.jme3.gde.core.j2seproject.ProjectExtensionManager]: Checking extension…

INFO [com.jme3.gde.core.j2seproject.ProjectExtensionManager]: Found assets-impl.xml

INFO [org.netbeans.ui.metrics.projects]: USG_PROJECT_OPEN

INFO [com.jme3.system.lwjgl.LwjglDisplay]: EDT: Sending re-init request…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Re-init request received!

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Destroying display (temporarily)

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Waiting for re-init authorization…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: EDT: Acknowledged receipt of re-init request!

INFO [com.jme3.system.lwjgl.LwjglDisplay]: EDT: Sending re-init authorization…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Re-init authorization received. Re-initializing…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Waiting for canvas to become displayable…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Creating display…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Waiting for display to become active…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Display is active!

INFO [org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater]: Resolving dependencies took: 2,203 ms

INFO [org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater]: Complete indexing of 31 binary roots took: 14859 ms

WARNING [org.openide.filesystems.Ordering]: Not all children in Menu/Tools/ marked with the position attribute: [OgreXML], but some are: [org-openide-actions-ToolsAction.shadow, I18N, Separator1.instance, JavaPlatformsCustomizerAction.shadow, VariablesCustomizerAction.shadow, LibrariesCustomizerAction.shadow, org-netbeans-modules-favorites-templates-TemplatesAction.shadow, org-netbeans-modules-xml-catalog-CatalogAction.shadow, PaletteManager, Separator2.instance, org-netbeans-modules-autoupdate-ui-actions-PluginManagerAction.shadow, Separator3.instance, org-netbeans-modules-options-OptionsWindowAction.shadow]

INFO [org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater]: Indexing of: jar:file:/C:/Program%20Files/jmonkeyplatform/ide/jsstubs/!/ took: 2672 ms (New or modified files: 0, Deleted files: 0) [Adding listeners took: 0 ms]

WARNING [org.openide.filesystems.Ordering]: Not all children in Menu/Window/ marked with the position attribute: [AssetPackBrowserAction.shadow, MaterialEditorAction.shadow, SceneExplorerAction.shadow, SceneViewerAction.shadow], but some are: [org-netbeans-modules-project-ui-logical-tab-action.shadow, org-netbeans-modules-project-ui-physical-tab-action.shadow, ViewFavoritesTabAction.shadow, org-netbeans-core-ide-ServicesTabAction.shadow, org-netbeans-modules-tasklist-ui-TaskListAction.shadow, ShowPaletteAction.shadow, org-netbeans-core-windows-actions-GlobalPropertiesAction.shadow, Output, Navigator, Debug, Profile, Versioning, Other, SwitchToRecentDocumentAction.shadow, ProgressListAction.shadow, Separator3.instance, CloseWindowAction.shadow, MaximizeWindowAction.shadow, org-netbeans-core-windows-actions-UndockAction.shadow, Separator4.instance, CloneDocumentAction.shadow, CloseAllDocumentsAction.shadow, CloseAllButThisAction.shadow, DocumentsAction.shadow, Separator5.instance, org-netbeans-core-windows-actions-ResetWindowsAction.shadow]

INFO [org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater]: Indexing of: file:/C:/Documents%20and%20Settings/Michael/My%20Documents/jMonkeyProjects/BasicGameTest/src/ took: 3235 ms (New or modified files: 0, Deleted files: 0) [Adding listeners took: 109 ms]

INFO [org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater]: Complete indexing of 2 source roots took: 5907 ms (New or modified files: 0, Deleted files: 0) [Adding listeners took: 109 ms]

WARNING [org.netbeans.core.TimableEventQueue]: too much time in AWT thread null

WARNING [org.netbeans.core.TimableEventQueue]: too much time in AWT thread null

INFO [org.netbeans.core.ui.sampler.SelfSamplerAction]: Slowness detector disabled - running under profiler

WARNING [org.netbeans.core.TimableEventQueue]: too much time in AWT thread null

If the rest of the log might be useful, I can post the whole thing, or look for anything specific.


I cannot find any current drivers for this card, one is supposed to get the newest drivers from the notebook manufacturer:

The description of the card only makes a rather dubious comment about OpenGL 2.0 compatibility. Due to the indeterministic behavior I’d say this is in fact a driver issue :confused:

It seems there are a lot of drivers that like to return 0 for glCreateProgram()? I am starting to feel like we might be doing something wrong with how we set up our shaders …

Hmmm. That’s a bummer. I’ve been away from the project for a year, and after spending yesterday working through the beginner tutorials, I was very impressed with the state of jME3, both the SDK and the tutorials. I tried running TestChooser from the SDK download and was able to get the menu, and the “settings” screen, but everything crashed after that. I was able to run JME2 without problem, so I’ll have to load up Eclipse and see if I can track down where it’s crashing.


I have the same problem. My simple application crashed in winwods (in linux ok, but i have different hardware for both machines)

problem has been solved with updating graphical driver (Radeon X300/x550/x1050 Series)