jMP freezes after "Starting Modules"

I run the updater for jMonkeyPlatform and it require a restart so I restarted it. The program ended up with the loading screen and some error that said:

“Warning - could not install some modules: Native Execution - The module named com.jcraft.jsch was needed and not found. CVS - The module named com.jcraft.jsch was needed and not found. 4 further modules could not be installed due to the above problem”

I choose to ignore that error and the loading continues. However at “Starting Modules” the whole thing freezes. Can anybody help me?

I get the same error message after the latest batch of updates, and it disables quite a few plugins along the way. However, my installation does NOT freeze at Starting Modules. It loads as normal - it simply has several plugins disabled.

I suggest you export your current settings (Tools → Options → Export, All) and reinstall the entire thing (removing the dev folder), try again. It can be a bit fickle.

Yeah, I did that, downloaded the sdk, works fine. Then I update and got the same crash.

Or freeze, not crash…

i had a few problems updating some non-jmp related plugins, try avoid updating those and see if it works.

I just updated to nightly and all plugins, incl. subversion and all the rest of the non-jmp plugins work splendidly. Make sure you don’t have the “NetBeans” update centers enabled, but only the Base Platform and jMonkey ones.

normen said:
Make sure you don't have the "NetBeans" update centers enabled, but only the Base Platform and jMonkey ones.

Is that deafult?! :O

Okey, now I installed the jMP again. I update and was sure that I didn’t choose any netbeans stuff. Guess what, I got same freeze!

Aww… Well you have been warned ^^ From beta on we try and keep the “stable” updates jME3 version more in sync with new features etc. as not too many jME3 API changes should happen from then on until jME 3.0 :). The platform base for the stable version will then not be updated anymore unless necessary which should provide reasonably up to date and stable SDK installs for people. Basically the same as the 3.0.X updates that will come after jME SDK 3.0 has been released.

That sounds great Normen! To be honest, I’ve never been quite sure whether I should be using the stable branch or the nightlies. I guess you’re saying that while Alpha lasts (not for much longer I suppose) Nightly is the way to go.

Really looking forward to Beta!

But I think I used the nightly stuff :S Well I guess I would stick to the stable stuff for a while…

I installed the current platform on Win7 (X86_64) but I’m getting this error too. I reinstalled Win7 a few weeks ago so I don’t have an existing JME installation. Any suggestions appreciated. This appears to be the beta version - is there a stable release? Are there any logfiles I can view? Thanks

There is only a Beta…however there is Stable and Nightly (both Beta).

It’s recommended for most people to use Stable unless they need something in the Nightly.

I downloaded this one:

Version 3.0 Beta

Date posted October 22, 2011

But it doesn’t work. I assume this is the Stable beta?