jMP IDE Freezes on OSX Mavericks (10.9.3)

Hi All,
The jMP IDE freezes during project configuration changes such as adding a shader or importing an obj model (basically any action taken in the ‘projects’ tab other than simply expanding a subtree to view its contents). Here’s a link to the relevant log:
freeze during project config

I saw this post which sounds similar, but I am only using one display so it doesn’t help.

any thoughts?

Did you try running “repair file permissions” in the disk utility?

I solved the permission denied errors by taking ownership of everything under the ‘Application Support/jmonkeyplatform/3.0’ directory. However, the IDE stills freezes during a model import of a .blend file and just after the creation of a new fragment shader.

here is a slightly more useful log, with a good-looking diagnostic information section

Hm, funny I don’t get this issue… The SDK Core itself also doesn’t really touch files starting with a dot in the assets folder… Did you apply all updates, also those coming from the NetBeans base platform?

I’d prefer not to run the repair permission utility; I have a number of custom permissions set. I did run the verify permissions utility and none of discrepancies appeared to be potentially related to jMonkeyEngine.

yes, all updates have been applied

Maybe try disabling background scanning of files in the application settings (Cmd-Comma), can’t check right now where exactly that option is though, sorry.

disabling auto scanning of sources didn’t help. I also tried increasing JVM RAM parameters and setting graphics.UseQuartz in jmonkeyplatform.conf to false; the IDE froze under the same circumstances as above.

Since the trouble seems to be coming from a NullPointerException at the assetpack creation/analysis stage, is there anything I can do to ensure the files the IDE is looking for are created manually? Is there a way to find out more about why the IOException “ Cannot create instance of com.jme3.gde.assetpack.browser.AssetPackBrowserTopComponent” occurs? A verbose logging mode, maybe?

I don’t think thats the issue, no.

Maybe try deleting the settings folder altogether and letting the SDK recreate it, you might have to re-apply the updates then though.

I deleted the settings folder, and now the IDE freezes at ‘starting modules’… this time deleting the cache folder, taking ownership of the settings folder and all files under the settings folder, and then re-launching the IDE didn’t solve the problem – it still freezes at starting modules.

Do you have old settings folders from previous versions? Any special tools running that modify the normal macbook graphics card switching and/or driver?

I don’t have any settings from older versions of jMP, no. The IDE is starting again now (deleting the cache folder again today worked for some reason), but it still freezes when performing operations under the projects tab. I have a mid-2012 Macbook Pro with a dual Intel HD Graphics 4000/Nvidia Geforce GTE 650M setup. I usually have graphics switching disabled in preferences, which ensures use of the 650M. I also have Nvidia CUDA installed, CUDA Driver Version: 6.0.46 and 650M driver version 8.26.21 310.40.35f08.

I tried enabling automatic graphics switching, but it didn’t change anything with respect to jMP’s freezing. Do you think the CUDA installation could be interfering somehow?

Hm, its possible, I have no idea though.

okay I got it – it turns out the problem was Netbeans’ (actually Java 7 update 45’s) to begin with (I’m an eclipse user so I didn’t catch this till I tried Netbeans 8.0 today and saw the same freezing behavior). It was solved by installing the latest jdk 7 from oracle (7_60 at time of writing) and commenting out the jdkhome=“jdk” line in /Applications/

Now I can edit preferences, create shaders, and import 3D models and everything appears to be working beautifully!

See here for the Netbeans forum discussion that led me to trying out a newer version of Java for OSX as the solution


/sigh Thanks for reporting back!