jmp3RC2 freezes since week: java null pointer error

Hi, I have the probs that JMP3 freezes now few secs after load, when I try to open a new project, or check the nullPointer info the jmp3 complains of.
How can I fix that?
Before it worked half a year (when we dont speak of the 3D-model window, which never worked).

I closed all projects in the hope it was something in the project-workspace, but seems not to help.
Where do I change the workspace from outside, is there a config-script?

here is the error log (I use Ubuntu-Linux version 2.6.32-50-generic running on i386):
[java]INFO [org.netbeans.core.ui.warmup.DiagnosticTask]: Total memory
INFO [null]: Total physical memory
SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor org.openid
at javax.swing.plaf.synth.SynthLookAndFeel.getStyle(SynthLookAndFeel.jav
at javax.swing.plaf.synth.SynthLookAndFeel.updateStyle(SynthLookAndFeel.
at javax.swing.plaf.synth.SynthMenuUI.updateStyle(
at javax.swing.plaf.synth.SynthMenuUI.propertyChange(
at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSup
at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSup

Change the LAF to the java default:

Looks the main prob was this (the freeze on 3D win is not nice, changing the LAF fixes it in some parts, but not to be able to open a new project is worse):

Strange that not much more linuxers report that. Looks everybody here works on Win, Mac, or Gentoo?

The release version 3.0 of the SDK has the proper Oracle JDK bundled so this should not be a problem anymore. We anyway always suggested using Oracles JDK but some seem to prefer the OpenJDK for some reason (I guess because its in the package managers).

Ok, I DLed the new stable JME3, but got errors on install:

Running the installer wizard…
[Error] wizard.xml.3:43:10: cvc-complex-type.2.4.b: Content des Elements “wizard” ist nicht vollständig. “{component}” wird erwartet.

I tried to use my old folder for the projcets. Maybe that was a prob?

Is there a way to change the projectfolder for JMP3 in some menue?

If I try to run the old projects I get:
/home/xxx/jMonkeyProjects/Civil_war/nbproject/build-impl.xml:790: Cannot run program “/home/xxx/jmonkeyplatform3/jdk/jre/bin/java” (in directory “/home/xxx/jMonkeyProjects/Civil_war”): error=13, Keine Berechtigung
at sun.reflect.GeneratedMethodAccessor53.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(

My java is:

:$java -version
java version “1.7.0_40”
Java™ SE Runtime Environment (build 1.7.0_40-b43)
Java HotSpot™ Client VM (build 24.0-b56, mixed mode)

(I had always a working oracle-JDK, no probs with eclipse and JME before)
OS is Ubuntu 10.04.4 LTS

New projects (BasicGame) seem to work.
Hmm, so I have to recreate my projects, or is there an easy fix?

“Keine Berechtigung” – there seems to be a user rights issue.

Yes =D

-There was no such prob in JME3 RC2, the projects in the same workspace still work there.
-There is no linux rights-difference from now new created projects like BasicGame and my older Projects in the same workspace. Its the same user, same rwxr-xr-x flags.

So I guess its a new jme3-stable issue. Any idea would be nice?

Meanwhile I’m copying my projects now by hand and paste them in new created projects from JME3stable, but thats not too nice.

See here:

Thanx, that fixed it, also update of the plugins works now (even if I have a 32bit).

Nice to have a working JME again. =D
Ah, and I like the ‘counting banana’ screen and the new menue/features, thank you for all your good work Normen and Monkey-team!