JVM Creation Failed


I’ve just installed the JMonkeyPlatform. When I try to start it I get this error: “JVM Creation Failed”. Only one time the software started and then ended because I needed NetBeans.

How can I solve the problem? Why the JVM Creation fails?

I work with Windows XP.

PS: Please write easy because I’m italian and I don’t speak english very well…

ufobm said:
PS: Please write easy because I'm italian and I don't speak english very well....

I'm Brazilian ;).
Did you already install the jdk in your machine? You don't need install netbeans to install jMPlataform.
1 Like

I installed this: http://hub.jmonkeyengine.org/downloads/?did=1

And then this: https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=jdk-6u23-oth-JPR@CDS-CDS_Developer

It’s ok?

Yes. Can you upload the error here? Perhaps uninstalling the jdk properly and reinstalling should works.

Yeah, you should be installing the jdk first (so in this case reinstall jmp)

I’ve already tried. Anyway I will try again tomorrow.

What should I upload? A screenshot?

ufobm said:
What should I upload? A screenshot?

Yes. But this problem already happened to me. And this just was solved when i uninstalled "properly" the jdk and reinstalled. When i said "properly" isn't just to remove the jdk installation, but to remove all jdk registers also. I removed all jdk registers in my machine executing the command line "regedit", then I removed the registers "one by one" searching for the word "java". Sometimes when you uninstall the jdk, it isn't removed properly, just you see still there is the "C:Program FilesJavajdk1.6.0_23" folder.

I reinstalled jmp. First I get an error saying that jdk wasn’t found. Then a critical error that blocked the system… And at the end I installed it successfully. But the error always appear… This is a screenshot.

I will try to uninstall also the jdk…

Nothing works… I uninstalled jmp and jdk. I cleaned the registers with the Advanced SystemCare Tool and then checked with the regedit command. Then I rebooted, installed the jdk, rebooted, installed the jmp, rebooted. But I always get the same error. I don’t believe the problem is the installation. Maybe I used the wrong software version. I used the ones I linked before.

Hmm! This is a memory problem, so you have to modify the jMonkeyPlataform’s startup settings to allocate more memory for it. It will stop running when it reached the limit of memory. Open the " C: Program Files jmonkeyplatform etc jmonkeyplataform.conf" file to modify the “-J-Xms24m” and “-J-Xmx512m” commands. If your machine is between 256 mb ram and 1gb ram then set it to “-Xms64m -Xmx1024m”. If it’s 2 gb or more then set it to “-Xms64m -Xmx1400” to get maximum performance. Hope this works ;).

Hi! I found the same solution on the NetBeans forum. It seems to work! My machine is 1gb RAM. I set the config to: -J-Xms24m -J-Xmx256m… Next time I will try with the values you said.

Thank you very much again!

My solution is to make “perm” option a comment as follows :

default_options="–branding jmonkeyplatform -J-Xms64m -J-Xmx1024m


in the jmonkeyplatform.conf file.

Anyway, your replies were very helpful, and Thank you so much…

PS : FYI, my environments are Windows XP and 7. jme3 is alpha-4.