Latest 3.1 Blender importer issue

I get an exception when using the latest blender importer (fresh from trunk).

Root cause:

Caused by: java.lang.ClassCastException: com.jme3.animation.BoneTrack cannot be cast to com.jme3.animation.SpatialTrack
    at com.jme3.scene.plugins.blender.animations.BlenderAction.toTracks(
    at com.jme3.scene.plugins.blender.animations.AnimationHelper.applyAnimations(
    at com.jme3.scene.plugins.blender.objects.ObjectHelper.toObject(
    at com.jme3.scene.plugins.blender.BlenderLoader.load(

Seemed like a straight forward issue so I tried to solve it by checking the instanceof the Track before adding it to the list. That solved the exception, and the model is loadable in the engine, but not in the editor (I’m using the 3.0 SDK).
I don’t know if it’s worth creating a pull request since I’m not really sure whether it fixes the issue for real.


I had this issue with one of my models, too… and did a similar fix that it sounds like you did and then the model didn’t load for a different (but seemingly related) reason. Like, then it didn’t have any tracks at all or something.

can you upload your model ? I will take a look.

Sorry, it’s a stock model. I’ll see if I can repeat it with another.

Sorry to necro this thread,
but I have precisely this problem. My animated model did import before, I added another animation and two more skeletons (for two more meshes of course) and this exception pops up on import.
Here’s my blend:,55213239/Hunchback_V06.blend/

Thanks in advance for any answers.