Libraries while plugin development are outdated


I encountered a strange problem: When developing an application, I have the current api, example: LightNode.setLight

But when developing plugins, the libraries are outdated, and LightNode.setLight becomes LightNode.setCamera

Now I have spent the last 11 hours trying to reinstalling, updating, building from svn, … and I still have this problem.

Is plugin development even supposed to work with current libraries? This sentence “Building the main freeform project copies the jme3 libraries to the sdk, so you should run its build script each time jme3 changes.” from build_platform :: jMonkeyEngine Docs made be believe so, but after all this failing I’m not sure anymore. Plus it breaks after multiple executions.

So, Any idea what I am doing wrong? Or isn’t this even supposed to work?

Well did you build the trunk folder project? Else the current jme3 libraries are not copied over.

1 Like

Yeah I’m building the trunk project. I followed the instructions on the wiki, and also tried all sorts of variations, either with no effect or errors during building.

No matter how often I download and install jmonkey, no harness is there. I tried harness from NetBeans 6.9.1, NetBeans 7.0.1, NetBeans 7.1.2, NetBeans 7.2 and the alpha avaible here:

The one from the alpha gave me the fewest errors during my attempts.

I installed all plugins with exception of the android stuff, checked the option to download nightly updates, installed the updates.

I checked out the svn, built the trunk project, opened the the sdk project, created a module suite, selected the platform, and added a project just as described in the wiki. There I have the old api with LightNode.setCamera, but at least I can run that project and see a new jmonkey sdk opening with my stuff in it.

Now some variations: I installed jmonkey to C: instead of C:Program Files. I opened the engine project, built it, run/built the sdk, tried to rebuilt/rerun the trunk, but again this either gives me no effect, or errors like “can’t copy stuff” because that stuff is appearently used by jmonkeyplatform.exe. When the latter happened, I closed jmonkey, deleted that stuff by hand, tried to build again, this time errors with harness and the hint to take a look at I did that, harness is defined there. I redefined it (no idea what I was doing there, so that’s basicly random attempts to make it work). I also tried following these instructions but with regular projects I allready had the current api, and with plugin projects I don’t know how to set the sdk libraries up to work with this… if this even makes any sense I don’t know…

I can try again and make a video of it if you want to see me fail.

Otherwise I would be happy if someone had a spare minute to set up jmonkey from installation to plugin development and record it. Because I’m really stuck here and don’t know what to do.

Please help me.

I’m trying to understand how to build modules from command line (for continuos integration builds) and netbeans sure does not make it easy with settings and importing files to the left and right :slight_smile: But googling for hours I’ve come as far as to also look for the harness directory in jME SDK and I can’t find it.

I did not compile jME from trunk, just a standard beta installation which works fine and I can make a working nbm-file from within the IDE. @cvlad did you install the plugin “Netbeans plugin development”?

normen, please tell us the secret of making hudson/jenkins build jME modules :slight_smile:

1 Like

@jmaasing: Yes, I installed it among all other plugins with exception of the android plugins.

I went to sleep with tons of errors and now that I fired it up again suddenly it seems to work. I don’t know what happened, I will try and retrace my last steps.

Checkout trunk and run ant in that folder once, the harness and everything else is downloaded automatically, the engine built and copied over to the SDK project. Then you canopen the SDK modules suite.