The next version of my little plugin is ready.

Point eclipse to the update site at

I checked it with md2 files and collada (collada without texture, don’t have any other object here right now).

After installing the plugin doubleclick one of your 3d files in eclipse, the editor opens (use awasd and qe to move around).

Now select  “save as” and the object gets saved as a jme file.



A screenshot from the plugin:

This looks like a great utility, but instead of doing something it makes eclipse not respond every time I double click a model, and I need to end the task.

I have tried drfreak.md2, man.dae, nordhorse.md3, and bike.3ds.

I am using xp pro and eclipse Version: 3.3.2 Build id: M20080221-1800 with full updates.

Any ideas?

…same behavior here…

I'm Using MyEclispe 6.0.

Ok, we have found the same behaviour on other machines.

Seems to be related to the ressource locator.

On one machine it took up to 4 Minutes for eclipse to load and respond.

I will work on that on monday.

I will also move the loading into an eclipse job so that eclipse won't hang even if something goes wrong.

Sorry for the inconvinience.

I will post in here as soon as the issue is resolved.

One questiob: did you have the dr freak texture in the same directory as the model?

do you use MultiformatResourceLocator maybe?

there was another thread about look up problems when using it

Ok, I found one bug, I left a wrong path in there.

I moved everything into a job and it works like a charm.

The final problem is the resolver.

ore-dump, could you point me to the thread.

I will debug the resourcelocator tomorrow but apparently under certain conditions it goes into an infinite loop.

I will try to fix that tomorrow and if it's a bug with the locator I will provide  a patch.

Make sure you are using the latest svn source as there was a recently fixed bug in the multiformat locator code.

Ok, after a weekend with way too much beer the next release is here.

The problem of hanging eclipse is solved:

  2. Loading is now done in an eclipse job

    Please remove the old plugin and install it from the update site again (sorry, had to change some stuff there)

    Remove: Open Help->Software Updates->Manage Configuration there rightclick Converter and JMESWT and select uninstall.

    Sorry, the next updates will be smoother.

    Problems that remain:
  • A coloring problem: Open drfreak, then bike.3ds, go back to drfreak and see him turn blue, will be fixed asap

Great, is working ok for me now…

Opened 3ds, obj and ms3d…