Minie v2.0

Version 2.0 of the Minie Physics Library was released today. It’s available from both GitHub and JCenter.

For details, see the release page at GitHub. For more details, see the release log.

2.0.0 is now the recommended release for all users.

11 Likes

Just updated! Will let you know if I find any issues.

1 Like

Excellent! will update today and report if have any issues
Thanks!

1 Like

would you consider packaging DAC as a runnable release it almost feels “hidden” in the way you have to access it unless I am missing something

Tell me more about what you have in mind.

It seems to me that it makes sense to present it a bit more “artist” friendly, again unless I am mistaken DAC is discussed upgraded but never actually “released” in the same vein as minie at least I don’t think so, new people who aren’t digging around might completely miss it…and other than the gradle run script I haven’t gotten it to run otherwise… my shortcomings aside though, it could simply stand to be a bit more accessible for something that is considered to be an editing tool.

a runnable jar zipped app

Are you talking about DynamicAnimControl itself, or are you talking about DacWizard, the application for configuring a DynamicAnimControl?

It would be easy to provide a runnable JAR for DacWizard. However, it’s not really designed as a tool for artists.

even so it could stand to be more visible like the minie releases IMHO at least

I’ve uploaded a ZIPped executable for DacWizard to the release page at GitHub. It’s the “DacWizard.zip” file, at the top of the “Assets” list.

I hope that’s what you’re requesting. If not, please be more specific.

Thanks
yes that what I mean, something you can just download and use, it is after all in your own words a tool, as I said it wasn’t readily available and if you are not actively following minie you probably would even miss that such a tool existed

1 Like

picked this below up trying to roll up to 2.0.1 strange thing is if I rollback to 2.0.0 get the same error. I’m trying to figure out if I have a classpath issue again or if there actual changes required between versions…seems weird that I can’t rollback though, at least on my eclipse version, which I suspect has issues in this regard especially when you copy/duplicate entire projects.

I have recompile the “maintained” 2.0.0 project several times to eliminate the possibility that my app was compiling on one version but executing on another version of minie, but that doesn’t seem to be the case, even “exported” ran it outside of eclipse to be certain, so I don’t know

Aug 14, 2020 7:26:34 PM com.jme3.app.LegacyApplication handleError
SEVERE: Uncaught exception thrown in Thread[jME3 Main,5,main]
java.lang.AbstractMethodError
	at com.jme3.app.state.AppStateManager.attach(AppStateManager.java:142)
	at hkr.start.Main_HKR.simpleInitApp(Main_HKR.java:36)
	at com.jme3.app.SimpleApplication.initialize(SimpleApplication.java:239)
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:132)
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:213)
	at java.lang.Thread.run(Unknown Source)

I feel like in the past couple weeks we had another user with ‘cache problems’ where jars were being used even though they were 100% sure they didn’t depend on them anymore. Specifically on Eclipse.

that was me, but I did the homework this time, I think my eclipse is broken, if nothing has indeed changed in minie

forgot the stack trace above

Ok I am unsure as to what make of this, other than 2.1 isn’t based on the last jme3 release but I doubt this is a class path issue

Downloaded the test case here

[SOLVED] How to make CharacterControl And DynamicAnimControl Ignore Each other?:slight_smile:

I get the model floating away in 2.0.0 (I suppose the bug under discussion)

and then 2.0.1 I get this

Exception in thread "main" java.lang.VerifyError: Bad type on operand stack
Exception Details:
  Location:
    hks/test/TestApp.switchNinjaToCharacterMode()V @35: invokespecial
  Reason:
    Type 'com/jme3/bullet/collision/shapes/CapsuleCollisionShape' (current frame, stack[2]) is not assignable to 'com/jme3/bullet/collision/shapes/ConvexShape'
  Current Frame:
    bci: @35
    flags: { }
    locals: { 'hks/test/TestApp', 'com/jme3/scene/Spatial', 'com/jme3/bullet/collision/shapes/CapsuleCollisionShape' }
    stack: { uninitialized 28, uninitialized 28, 'com/jme3/bullet/collision/shapes/CapsuleCollisionShape', float }
  Bytecode:
    0x0000000: 2ab4 0060 03b6 0062 4c2b 0b12 680b b600
    0x0000010: 6957 bb00 6f59 0d0d b700 714d bb00 7459
    0x0000020: 2c12 76b7 0077 4e2d 127a b600 7b2d 127f
    0x0000030: b600 802a b400 6003 b600 6212 83b6 0085
    0x0000040: c000 833a 0419 04c6 0035 0336 05a7 0024
    0x0000050: 2db6 0089 1904 b600 8d15 0532 b600 9119
    0x0000060: 04b6 008d 1505 322d b600 89b6 0097 8405
    0x0000070: 0115 0519 04b6 008d bea1 ffd7 2ab4 0060
    0x0000080: 2db6 009a 2ab4 0059 b600 9e2d b600 a2b1
    0x0000090:                                        
  Stackmap Table:
    full_frame(@80,{Object[#1],Object[#106],Object[#111],Object[#116],Object[#131],Integer},{})
    same_frame(@113)
    chop_frame(@124,1)

	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
	at java.lang.Class.privateGetMethodRecursive(Unknown Source)
	at java.lang.Class.getMethod0(Unknown Source)
	at java.lang.Class.getMethod(Unknown Source)
	at sun.launcher.LauncherHelper.validateMainClass(Unknown Source)
	at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

Ok I threw it all out and started over new eclipse, new workspace, new project folder everything works again I really don’t understand what happened there

Why don’t you use InteliJ? I think it’s much easier to work on than Eclipse…

@adi.barda I operate out of a user account Intellij seemed to take issues with that, plus “familiarity” I find myself less willing to deal with solving annoyances in my relative old age :wink: but if “annoyances” with eclipse persist I may have no choice but to figure intellij out

does it have an intellij setup tut for jme3 though

One of the side-effects of Eclipse doing everything “different than every other IDE on the planet” is that it’s hard for folks to switch. Where as it’s more straight forward to switch between IDEs like Netbeans and IntelliJ with only a little translation… Eclipse is its own beast.

You can use the this project as a starter template. Just update the grade file when you need to add more components to your game:

https://drive.google.com/file/d/1rBtYyTsJAsw9doViV61GkgFD9jVyWdQ_/view?usp=sharing

1 Like

ok thanks