miniLD#20: Greedy Fishing

Hola party-people,

this weekend was a miniLD 48h game coding competition and although I was at a birthday yesterday

I tried to finish something. First time I really used nifty and it worked quite well. Actually I only used

very basic stuff. Have a look here:

Here are the rules for that miniLD(theme greed or fishing with a nice restriction):

EDIT: Ooh…now I used the wrong general-folder! Sry,… sbook/erland could you move this to the other folder!? Thx

Cool, a game :smiley:

what are the controls ?

Well, actually there are no controls beside the mouse-button. Fishing is done automatically,

your task is only to decide if you want to give it another try and think the next fish won't

exceed you boat's weight-limit…

(yeah, I know a bit lame! :smiley: )

Ok,… I invested 2 more days for changing some stuff. e.g. the guys can drink beer (can't imagine something more important for an animated model :smiley: ) and changed lot's about the game itself:

Have a look here:

Free Beer!  :-o Cool  :smiley:

Actually the beer drinking has no sense. I planned to add nice drunk-animations but I

have to admit that I rigged the model in 10ms and had to pay the whole time :smiley:

So it was not soo easy adding cool animations…next time! :smiley:

Keep on rocking und prost :smiley:

ttrocha said:

Actually the beer drinking has no sense.

the guy is fishing...he drinks a beer...makes pretty much sense to me.  :P

Very nice!

I like the sound of the sea and that big fish jumping into the screen!

I'm wondering if there is a focus problem with the "go on" button when you've caught something though?

If I have the mouse pointer over the button already when the button is shown I have to either move the mouse or click once in order to be able to click on the button again (sorry for the strange description, I hope it's understandable).

I'm wondering if there is a focus problem with the "go on" button when you've caught something though?

Yes! That stands on my 'bug' list. I didn't had time to examine that yet. The problem is that I have different
layers that I add and remove from the screen. (I'm not using different screens, but for sure would be the best case but I didn't know how to handle the hud, that should be visible everytime) in that way). And it seems that the mouse needs some refresh (that is only done by some action) in order to find the underlying elements. I think I saw something like this, but I'm not sure,...

I'm quite sure I made the problem by using nifty-gui in a strange way :D

Thx for testing and feedback

ah now i get it :slight_smile: thats cool