Model looks fine at blender but it is black at JME


#1

Hi,

Currently, I am using OpenDS, a JME based driving simulator. This open source software allows me use XML to add 3D model into my scene.

I have download a road sign and it looks fine at blender.
image

But when I use XML to add model to the scene and it looks like
image

I have tried add lamp but it does not work. The build-in model (road sign ) is fine and that model is ogre3D (.scene). Also, I have tried export the model into orge3D. The model is rotated and become pink said not texture found.

Could someone give me some advice about how to fix it?

Thank you so much.

CHase


#2

questions are:

  • how your sceneGraph looks like?
  • where you add this light(is it RootNode?). and what type of light
  • what material are this objects

#3

Hi oxplay2 thank you for answering.

  1. The scene graphic of this model is looks like
  1. For this one, I did not add any light. In the XML it has the directional light. So the model itself does not has light.

  2. I am not pretty sure about the material. I download the free model.

Sorry I do not have much experience at building 3D model.


#4

Load the model in the SDK.

Find the geometry.

Generate the j3m for the material.

Post the j3m here.

…good bet is that if the scene is lit then the diffuse and ambient colors of the model are set to black.


#5

by telling how sceneGraph look i mean something like:

rootNode -> objectsNode -> DirectionalLight
                        -> sign
         -> roadNode -> roadGeom
                     -> AmbinetLight

or anything different. i also dont know how this XML build it, but you might build it wrong there.

tips:

  • like @pspeed said, see in SDK (open model, add new material, toggle pointLight and see)
    you can then add in SceneGraph other lights to see effects.
  • add light in some parentNode. (via xml you use?)
  • in code just do rootNode.addLight(new AmbientLight(some params)) to see any effect.

#6

I loaded the model into SDK and it looks like this,

seems like it does not find the texture.


#7

main problem for me is that i dont know how this XML system work.

anyway this dont even tried to find texture, if it would not find then there would be yellow texture with text “not found texture” or something similar.

try add proper material into it, but still i think your XML build scene without proper light.
i mean road is visible, but it might be unshaded material, while sign is lighting material probably, so your scene dont have light probably so unshaded is visible, but lighting not.


#8

Click that properties data button pointed to by the yellow arrow.

Use imgur to paste in the image and generate the link.

Post link.


#9

Hi, mitm

Here is the image.


#10

Has uvmap so do as paul said.

https://wiki.jmonkeyengine.org/sdk/material_editing.html#using-j3m-materials

If the .j3o file already has a material assigned to it from exporting/importing, you can generate the material by selecting “create j3m file” instead.


#11

Has your issue been resolved yet?