Multi View with Multi HUD Problem

this is 800x600 display


As you can see at the image above that my soon-to-be lap counter text is not showing on the second screen. My question is what is the value/coordinate of the bottom left corner of the 2nd screen? I did my multi views like in the jme3test.renderer.TestMultiViews.

I have placed both text on (1, text.getLineHeight(), 0);

  • only the 1st screen has the text so I thought that the second screen is starting at 401 to 800 (from 800x600 display), still got no luck.

    I have placed both text on (settings.width()-text.getLineWidth(), text.getLineHeight(), 0);
  • both texts did not show.

    My conclusion,

    screen1 bottom-left is at 0, 0

    screen1 bottom-right is at 400, 0

    screen2 bottom-left is at ??? and not 401, 0

    screen2 bottom-right is at ??? and not 800, 0

    Please help me with this.

    Thank you

Have you tried using 0,0 and 400,0 on second screen? I would expect it to be that way if it’s a second canvas/screen.

It’s just a guess though.

yes i have tried using 400,0 and 0, 0 on the second screen… any values that i tried never make it to appear on the second screen…

@Momoko_fan I noticed that kind of issue with multi views. Parallel projection rendered scenes are not properly scaled. the error seems to be in renderManager.setViewPort

@blur i’m on it.

mmmhh…it’s working for me if i use text.setLocalTranslation(400,text.getLineHeight(),0)

you have 2 gui viewports or only one?

with one it works for me

I have 2 gui viewports. Each gui viewPort has guiNode and text. I split the screen from a custom class. From there it creates its own gui viewPort and guiNode.

Actually if I set the race to 4 players it will split the screen to 4 . Which means it will have 4viewPorts, 4 gui viewPorts and 4 guiNodes. I haven’t tried it yet with 1 gui viewport… I have to try that…

Thank you guys. :smiley:

Ok in the meantime i’m going to test with several gui viewports.

Sounds like one of your gui viewports has clear set where it shouldn’t

I tried constructing my problem in a test class using simple application. Using 1 and 2 gui view ports worked. There’s really something wrong with my custom class.

Thank you guys…

I got it, its now working… Theres nothing wrong with my gui viewPorts and guiNodes. It just the gui cam that makes the problem. I have used guiCam.setViewPort() and .setFrustrumPerspective() which I think should not be there.

Thank you… :slight_smile: