Multiplayer Problem

I just got the game a few days ago, and i think it is awesome, but when I try to connect to a server using one of my profiles, or even with a new profile, it says the following:Connection Failed= Error Connecting to Server! I have tried everything and it still has the same outcome. I updated to v2.4.13b, so i do not know what else to do.

What was the server you were trying to connect to? Might have been a problem on the server’s end…

i tried two test servers that you launched, 3 servers from twitter, and 1 from steam 3079 multiplayer fan group.

Likely the people were not hosting the servers anymore, or they mistakenly provided a local IP address (e.g.

ok me and Companion Cube is Not Amused(server owner of server for 3079 steam multiplayer group) tried to open up his server and when I joined it, using both Hamachi and the regular server Ip, it still came out the same. I then uninstalled 3079, then reinstalled it. It still came out the same D: Please help!

Getting the “failed to connect to server” message?

What was the regular server IP you were trying to use?

The version I am putting out now, v2.5.3b, will do a much better job at reporting the correct IP people should connect to.

server ip was

Is this server supposedly always up? I can’t seem to access it, or even ping it now. I can’t really troubleshoot it if I cannot connect to it :confused:

Our big problem is we get allota times were we have to delete characters becuase on our mp terrain doesn’t load. Which sticks the character, relogging doesn’t help. Or finding patches of corrupted terrain.

You shouldn’t have to ever delete a character – try using “/goto 0 0” in the console to teleport out of stuck terrain. Are you guys using v2.5.3b?

Yea we are. were debating if its our connection or hamachi doing it. We’ll be hosting later if you wanna join in and see. big problem is some players see the area not load, and it never loads for them, others it loads and they walk through it. That combined with the slowdowns when hosting. I’m wondering if its connection or pc issues.

Been doing some testing. Singleplayer works perfectly. Still having issues though with multiplayer. I’m wondering if you have clients storing the map data. And if so, is it possible on occasion with us were getting bad packets which are saving corrupt data from the server and not reloading? If so ya might wanna put a CRC/MD5 check in on reload to a server to ensure everything is correct.

Not knowing how the game does transmitting,

I think he uses tcp for sending the data, so by default there already is a crc on packet basis, so i assume the transmitted data is not false.

True, but there’s still some issue. I’ve done game dev for a while and it looks like notches “unloaded chunk” issue.

I do use TCP for communication…

I’m not sure of the original cause of this problem yet. It could be people with slow connections are getting chunk updates late, or it could be something else. What slowdowns are you talking about – slowdowns on the server, or the clients?

@phr00t said:
Is this server supposedly always up? I can't seem to access it, or even ping it now. I can't really troubleshoot it if I cannot connect to it :/

Not always, you would have to ask Companion cube is not amused on steam, and he would put it up.